An issue was discovered in Mailman Core before 3.3.5.
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-208.
Summary
An issue was discovered in Mailman Core before 3.3.5. An attacker with access to the REST API could use timing attacks to determine the value of the configured REST API password and then make arbitrary REST API calls. The REST API is bound to localhost by default, limiting the ability for attackers to exploit this, but can optionally be made to listen on other interfaces.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mailman (PyPI) | before 3.3.5 | 3.3.5 | Patch available | GHSA-2jg5-xgvv-4wq7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mailman (PyPI) Vendor— Affected before 3.3.5 Fixed in 3.3.5 Patch available GHSA-2jg5-xgvv-4wq7
Remediation
- Fix · GHSA-2jg5-xgvv-4wq7 mailman (PyPI) Fixed in 3.3.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-34337
- 2026-10-03 Alias added: GHSA-2jg5-xgvv-4wq7
References
More GNU Mailman vulnerabilities
- TI-2025-28486 Path traversal in GNU Mailman CVSS 3.1HIGH 7.5
- TI-2025-28487 OS command injection in GNU Mailman CVSS 3.1HIGH 8.1
- TI-2025-28488 Incorrect authorization in GNU Mailman CVSS 3.1MEDIUM 5.3
- TI-2015-02450 Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static… CVSS 2.0HIGH 7.6
- TI-2002-00830 Cross-site scripting vulnerability in Mailman before 2.0.12 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2002-00374 Cross-site scripting vulnerabilities in Mailman before 2.0.11 allow remote attackers to… CVSS 2.0HIGH 7.5
Sources
- CVE-2021-34337 · CVE Program
- CVE-2021-34337 · NVD
- FIRST EPSS
- GHSA-2jg5-xgvv-4wq7 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-34337 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences