Read the docs

GoodLayers

Records22All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical5CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

GoodLayers records in CISA KEV

No GoodLayers vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

22 records

TI-2024-11504 CVE-2024-12400 · GHSA-xr4j-2qp3-r4xc

Tourmaster < 5.3.5 - Reflected XSS

Priority MEDIUM 64

The tourmaster WordPress plugin before 5.3.5 does not escape generated URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting.

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00285 Published 2025-01-30 Fixed in 5.3.5 CWE-79
Priority MEDIUM 62

The goodlayers-core WordPress plugin before 2.1.3 allows users with a subscriber role and above to upload SVGs containing malicious payloads.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00285 Published 2025-01-30 Fixed in 2.1.3 CWE-79
TI-2024-10989 CVE-2024-11846 · GHSA-f4x6-mr29-4g4q

Travel Tour < 5.2.4 - Reflected XSS

Priority MEDIUM 60

The does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00373 Published 2025-01-01 Fixed in 5.2.4 CWE-79
Priority MEDIUM 60

The goodlayers-core WordPress plugin before 2.0.10 does not sanitise and escape some of its settings, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00331 Published 2025-01-02 Fixed in 2.0.10 CWE-79
Priority MEDIUM 60

The tourmaster WordPress plugin before 5.3.4 does not sanitise and escape some parameters when outputting them in the page, which could allow unauthenticated users to perform Cross-Site Scripting attacks.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00365 Published 2025-01-06 Fixed in 5.3.4 CWE-79
Priority MEDIUM 54

An unauthenticated SQL Injection vulnerability in Good Layers LMS Plugin <= 2.1.4 exists due to the usage of "wp_ajax_nopriv" call in WordPress, which allows any unauthenticated user to get access to the function "gdlr_l…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.09762 Published 2020-11-12 No fix listed CWE-89
Priority MEDIUM 46

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in GoodLayers Goodlayers Hotel gdlr-hotel allows Blind SQL Injection.This issue affects Goodlayers Hotel: from n/a throug…

CVSS 3.1CRITICAL 9.3 Network No auth No interaction EPSS 0.00454 Published 2025-05-23 No fix listed CWE-89
Priority MEDIUM 46

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in GoodLayers Goodlayers Hostel gdlr-hostel allows Blind SQL Injection.This issue affects Goodlayers Hostel: from n/a thr…

CVSS 3.1CRITICAL 9.3 Network No auth No interaction EPSS 0.00454 Published 2025-05-23 No fix listed CWE-89
Priority MEDIUM 40

Incorrect Privilege Assignment vulnerability in GoodLayers Goodlayers Core goodlayers-core allows Privilege Escalation.This issue affects Goodlayers Core: from n/a through < 2.1.7.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00391 Published 2025-10-22 No fix listed CWE-266
Priority LOW 39

The Tour Master - Tour Booking, Travel, Hotel plugin for WordPress is vulnerable to time-based SQL Injection via the ‘review_id’ parameter in all versions up to, and including, 5.3.7 due to insufficient escaping on the u…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00487 Published 2025-02-18 No fix listed CWE-89
Priority LOW 38

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in GoodLayers Tourmaster tourmaster allows PHP Local File Inclusion.This issue affects Tourmaster: fro…

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.00664 Published 2025-05-23 No fix listed CWE-98
Priority LOW 33

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GoodLayers Goodlayers Blocks goodlayers-blocks allows Reflected XSS.This issue affects Goodlayers Blocks: from n/a thr…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.0037 Published 2025-03-03 No fix listed CWE-79
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GoodLayers Goodlayers Hotel gdlr-hotel allows Reflected XSS.This issue affects Goodlayers Hotel: from n/a through <= 3…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00288 Published 2025-05-23 No fix listed CWE-79
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GoodLayers Goodlayers Hostel gdlr-hostel allows Reflected XSS.This issue affects Goodlayers Hostel: from n/a through <…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00288 Published 2025-05-23 No fix listed CWE-79
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GoodLayers Tourmaster tourmaster allows Reflected XSS.This issue affects Tourmaster: from n/a through < 5.4.1.

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00237 Published 2025-04-15 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GoodLayers Modernize modernize allows Stored XSS.This issue affects Modernize: from n/a through <= 3.4.0.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00235 Published 2025-08-14 No fix listed CWE-79
Priority LOW 27

The Goodlayers Core plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘font-family’ parameter in all versions up to, and including, 2.0.7 due to insufficient input sanitization and output escap…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.0033 Published 2024-12-03 No fix listed CWE-79
Priority LOW 20

Missing Authorization vulnerability in GoodLayers Modernize modernize allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Modernize: from n/a through <= 3.4.0.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00263 Published 2025-08-14 No fix listed CWE-862
Open these records in search →