Read the docs

metaphorcreations

Records31All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high4CVSS 7.0–8.9

Exploited now

metaphorcreations records in CISA KEV

No metaphorcreations vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

10 records in Ditty · all components

TI-2025-07398 CVE-2025-8085 · GHSA-5w55-fgg7-m5gx

Ditty < 3.1.58 - Unauthenticated SSRF

Priority HIGH 76

The Ditty WordPress plugin before 3.1.58 lacks authorization and authentication for requests to its displayItems endpoint, allowing unauthenticated visitors to make requests to arbitrary URLs.

CVSS 3.1HIGH 8.6 Network No auth No interaction EPSS 0.20083 Published 2025-09-08 Fixed in 3.1.58 CWE-918
TI-2024-06224 CVE-2024-6715 · GHSA-wp3m-rhjq-59fj

Ditty 3.1.39-3.1.45 - Author+ Stored XSS

Priority MEDIUM 60

The Ditty WordPress plugin before 3.1.46 re-introduced a previously fixed security issue (https://wpscan.com/vulnerability/80a9eb3a-2cb1-4844-9004-ba2554b2d46c/) in v3.1.39

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00347 Published 2024-08-23 Fixed in 3.1.46
TI-2023-03837 CVE-2023-4148 · GHSA-m968-5jwq-gjrc

Ditty < 3.1.25 - Reflected XSS

Priority MEDIUM 60

The Ditty WordPress plugin before 3.1.25 does not sanitise and escape some parameters and generated URLs before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against hi…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00845 Published 2023-09-25 Fixed in 3.1.25 CWE-79
TI-2024-06219 CVE-2024-6710 · GHSA-wfr9-cxf9-hqxv

Ditty < 3.1.45 - Author+ Stored XSS

Priority MEDIUM 58

The Ditty WordPress plugin before 3.1.45 does not sanitise and escape some parameters, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00354 Published 2024-08-05 Fixed in 3.1.45 CWE-79
Priority MEDIUM 55

The Ditty WordPress plugin before 3.1.52 does not sanitise and escape some of its settings, which could allow high privilege users such as author to perform Stored Cross-Site Scripting attacks even when the unfiltered_ht…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 3.1.52 CWE-79
TI-2024-08907 CVE-2024-9600 · GHSA-8w85-45qx-p356

Ditty < 3.1.47 - Author+ Stored XSS

Priority MEDIUM 55

The Ditty WordPress plugin before 3.1.47 does not sanitise and escape some of its settings, which could allow high privilege users such as author to perform Stored Cross-Site Scripting attacks.

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00399 Published 2024-11-21 Fixed in 3.1.47 CWE-79
TI-2024-05179 CVE-2024-5575 · GHSA-c9r8-cg3x-whrc

Ditty < 3.1.43 - Author+ Stored XSS

Priority MEDIUM 55

The Ditty WordPress plugin before 3.1.43 does not sanitise and escape some of its blocks' settings, which could allow high privilege users such as authors to perform Cross-Site Scripting attacks even when unfiltered_html…

CVSS 3.1MEDIUM 4.7 Network No auth User interaction EPSS 0.00435 Published 2024-07-13 Fixed in 3.1.43 CWE-79
Priority LOW 25

The Ditty WordPress plugin before 3.1.36 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_htm…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00399 Published 2024-05-27 Fixed in 3.1.36 CWE-79
Open these records in search →