Ditty – Responsive News Tickers, Sliders, and Lists < 3.1.52 - Author+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ditty WordPress plugin before 3.1.52 does not sanitise and escape some of its settings, which could allow high privilege users such as author to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ditty (Unknown): 3.1.52
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ditty | before 3.1.52 | 3.1.52 | Patch available | CNA |
- Ditty VendorUnknown Affected before 3.1.52 Fixed in 3.1.52 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metaphorcreations:ditty:*:*:*:*:*:wordpress:*:* | before 3.1.52 | Vulnerable | metaphorcreations |
- cpe:2.3:a:metaphorcreations:ditty:*:*:*:*:*:wordpress:*:* Versions before 3.1.52 Vulnerable ·metaphorcreations
Remediation
- Fix · CNA Ditty (Unknown) Fixed in 3.1.52
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13357
- 2026-10-03 Alias added: GHSA-pvvp-x3x5-w98p
References
More metaphorcreations Ditty vulnerabilities
- TI-2025-07398 Ditty < 3.1.58 - Unauthenticated SSRF CVSS 3.1HIGH 8.6
- TI-2024-06224 Ditty 3.1.39-3.1.45 - Author+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-03837 Ditty < 3.1.25 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2024-06219 Ditty < 3.1.45 - Author+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-08907 Ditty < 3.1.47 - Author+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-05179 Ditty < 3.1.43 - Author+ Stored XSS CVSS 3.1MEDIUM 4.7
Sources
- CVE-2024-13357 · CVE Program
- CVE-2024-13357 · NVD
- FIRST EPSS
- GHSA-pvvp-x3x5-w98p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences