template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, wh…
CVSS 2.0HIGH 8.5·Network·Low privileges·Interaction —·EPSS 0.03291·Published 2010-12-09·Fixed in 2.0.7CWE-94
The web interface (CobblerWeb) in Cobbler before 1.2.9 allows remote authenticated users to execute arbitrary Python code in cobblerd by editing a Cheetah kickstart template to import arbitrary Python modules.
CVSS 2.0HIGH 9.0·Network·Low privileges·Interaction —·EPSS 0.02163·Published 2009-08-12·Fixed in 1.2.9CWE-264
Incomplete blacklist vulnerability in action_power.py in Cobbler 2.2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) username or (2) password fields to the power_system method…
CVSS 2.0HIGH 7.5·Network·No auth·Interaction —·EPSS 0.05538·Published 2012-06-16·Fixed in 2.6.0CWE-77
Cobbler before 1.6.1 does not properly determine whether an installation has the default password, which makes it easier for attackers to obtain access by using this password.
Cobbler before 2.0.4 uses an incorrect umask value, which allows local users to have an unspecified impact by leveraging world writable permissions for files and directories.