Incomplete blacklist vulnerability in action_power.py in Cobbler 2.2.0 allows remote…
Priority MEDIUM 41CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-77.
Summary
Incomplete blacklist vulnerability in action_power.py in Cobbler 2.2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) username or (2) password fields to the power_system method in the xmlrpc API.
Why it matters now
EPSS 0.05538 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed cobbler (PyPI): 2.6.0Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | before 2.6.0 | 2.6.0 | Patch available | GHSA-g34c-mg6m-xvxj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected before 2.6.0 Fixed in 2.6.0 Patch available GHSA-g34c-mg6m-xvxj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:michael_dehaan:cobbler:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Michael Dehaan |
- cpe:2.3:a:michael_dehaan:cobbler:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Michael Dehaan
Remediation
- Fix · GHSA-g34c-mg6m-xvxj cobbler (PyPI) Fixed in 2.6.0 Advisory →
Red Hat 1 advisory
- RHSA-2012:1060 Released 2012-07-09 · Red Hat rating Moderatecobbler security update
- Red Hat Satellite 5.4 (RHEL v.5) cobbler-2.0.7-14.6.el5sat
- Red Hat Satellite 5.4 (RHEL v.6) cobbler-2.0.7-14.6.el6sat
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 5.4 (RHEL v.5) | Fixed | RHSA-2012:1060 |
| Red Hat Satellite 5.4 (RHEL v.6) | Fixed | RHSA-2012:1060 |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-2395
- 2026-10-03 Alias added: GHSA-g34c-mg6m-xvxj
References
Other 12
- [oss-security] 20120523 CVE request: cobbler command injection
- [oss-security] 20120523 Re: CVE request: cobbler command injection
- https://bugs.launchpad.net/ubuntu/+source/cobbler/+bug/978999
- https://github.com/cobbler/cobbler/issues/141
- 82458
- https://github.com/cobbler/cobbler
- https://lists.opensuse.org/opensuse-security-announce/2012-05/msg00016.html
- https://lists.opensuse.org/opensuse-security-announce/2012-07/msg00000.html
- https://web.archive.org/web/20120712025653/http://www.securityfocus.com/bid/53666
- https://www.openwall.com/lists/oss-security/2012/05/23/18
- https://www.openwall.com/lists/oss-security/2012/05/23/4
- https://www.osvdb.org/82458
More Michael Dehaan Cobbler vulnerabilities
- TI-2010-02144 template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and… CVSS 2.0HIGH 8.5
- TI-2008-06642 The web interface (CobblerWeb) in Cobbler before 1.2.9 allows remote authenticated users… CVSS 2.0HIGH 9.0
- TI-2009-04777 Cobbler before 1.6.1 does not properly determine whether an installation has the default… CVSS 2.0HIGH 7.5
- TI-2010-04242 Cobbler before 2.0.4 uses an incorrect umask value, which allows local users to have an… CVSS 2.0HIGH 7.2
Sources
- CVE-2012-2395 · CVE Program
- CVE-2012-2395 · NVD
- FIRST EPSS
- GHSA-g34c-mg6m-xvxj · GitHub Advisory Database · CC BY 4.0
- CVE-2012-2395 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences