Vendors / Mongo-express Project Records 5 All Threatist records
Exploited (KEV) 1 In CISA KEV
CVSS critical 2 CVSS 9.0–10.0
CVSS high 2 CVSS 7.0–8.9
Exploited now Mongo-express Project records in CISA KEV
Components Products in the NVD configurations · select one to filter the records Priority CRITICAL 100KEV
mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method.
CVSS 3.1 CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.84726 · Published 2019-12-24 · Fixed in 0.54.0 CWE-94
Priority HIGH 81
mongo-express before 1.0.0 offers support for certain advanced syntax but implements this in an unsafe way.
CVSS 3.1 CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.74519 · Published 2021-03-30 · Fixed in 2.0.0 CWE-20
Priority MEDIUM 60
In mongo-express 1.0.2, /admin allows CSRF, as demonstrated by deletion of a Collection.
CVSS 3.1 MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00206 · Published 2024-03-01 · No fix listed CWE-352
Priority LOW 38
mongo-express is a web-based MongoDB admin interface, written with Node.js and express.
CVSS 3.1 HIGH 8.1· Network · No auth · User interaction · EPSS 0.0157 · Published 2021-06-21 · Fixed in v1.0.0-alpha.4, 1.0.0-alpha.4 CWE-79
Priority LOW 35
All versions of package mongo-express are vulnerable to Denial of Service (DoS) when exporting an empty collection as CSV, due to an unhandled exception, leading to a crash.
CVSS 3.1 HIGH 7.5· Network · No auth · No interaction · EPSS 0.0091 · Published 2021-04-13 · No fix listed CWE-754
Open these records in search → All records by CVSS severity
Critical2 High2 Medium1 Low0 No CVSS0