mongo-express before 1.0.0 offers support for certain advanced syntax but implements this…
Priority HIGH 81CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
mongo-express before 1.0.0 offers support for certain advanced syntax but implements this in an unsafe way. NOTE: this may overlap CVE-2019-10769.
Why it matters now
EPSS 0.74519 99th percentileScored 2026-11-07
Fix Fixed mongodb-query-parser (npm): 2.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mongodb-query-parser (npm) | before 2.0.0 | 2.0.0 | Patch available | GHSA-hxmg-hm46-cf62 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mongodb-query-parser (npm) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-hxmg-hm46-cf62
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongo-express_project:mongo-express:*:*:*:*:*:node.js:*:* | up to 0.54.0 | Vulnerable | Mongo-express Project |
- cpe:2.3:a:mongo-express_project:mongo-express:*:*:*:*:*:node.js:*:* Versions up to 0.54.0 Vulnerable ·Mongo-express Project
Remediation
- Fix · GHSA-hxmg-hm46-cf62 mongodb-query-parser (npm) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-24391
- 2026-10-03 Alias added: GHSA-hxmg-hm46-cf62
References
More Mongo-express Project Mongo-express vulnerabilities
- TI-2019-08023 Code injection in mongo-express KEVCVSS 3.1CRITICAL 9.9
- TI-2023-28898 In mongo-express 1.0.2, /admin allows CSRF, as demonstrated by deletion of a Collection. CVSS 3.1MEDIUM 6.1
- TI-2021-04520 XSS Vulnerability in mongo-express CVSS 3.1HIGH 8.1
- TI-2021-06065 Denial of service (DoS) in mongo-express CVSS 3.1HIGH 7.5
Sources
- CVE-2020-24391 · CVE Program
- CVE-2020-24391 · NVD
- FIRST EPSS
- GHSA-hxmg-hm46-cf62 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences