Read the docs

Nagios

Records303All Threatist records
Exploited (KEV)4In CISA KEV
CVSS critical52CVSS 9.0–10.0
CVSS high102CVSS 7.0–8.9

Exploited now

Nagios records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

19 records in Fusion · all components

Priority MEDIUM 49

Incorrect SSL certificate validation in Nagios Fusion 4.1.8 and earlier allows for Escalation of Privileges or Code Execution as root via vectors related to download of an untrusted update package in upgrade_to_latest.sh…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.04495 Published 2021-05-24 No fix listed CWE-295
Priority MEDIUM 48

Insufficient Verification of Data Authenticity in Nagios Fusion 4.1.8 and earlier and Nagios XI 5.7.5 and earlier allows for Escalation of Privileges or Code Execution as root via vectors related to an untrusted update p…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03115 Published 2021-05-24 No fix listed CWE-345
Priority LOW 30

Nagios Fusion versions prior to 4.2.0 contain a stored cross-site scripting (XSS) vulnerability when adding or configuring Email Settings.

CVSS 4.0MEDIUM 6.2 Network High privileges User interaction EPSS 0.01003 Published 2025-10-30 Fixed in 4.2.0 CWE-79
Priority LOW 29

Nagios Fusion versions prior to 4.2.0 contain a stored cross-site scripting (XSS) vulnerability in the LDAP/AD authentication-server configuration.

CVSS 4.0MEDIUM 6.2 Network High privileges User interaction EPSS 0.0082 Published 2025-10-30 Fixed in 4.2.0 CWE-79
Priority LOW 29

Nagios Fusion versions prior to 4.2.0 contain a reflected cross-site scripting (XSS) vulnerability in the license key configuration flow that can result in execution of attacker-controlled script in the browser of a user…

CVSS 4.0MEDIUM 6.0 Network High privileges User interaction EPSS 0.00885 Published 2025-10-30 Fixed in 4.2.0 CWE-79
Priority LOW 24

Nagios Fusion versions prior to 4.1.5 are vulnerable to cross-site scripting (XSS) via the "fusionwindow" parameter.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00516 Published 2025-10-30 Fixed in 4.1.5 CWE-79
Priority LOW 24

Nagios Fusion versions prior to 4.0.1 are vulnerable to cross-site scripting (XSS) via the Users and Servers pages.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00516 Published 2025-10-30 Fixed in 4.0.1 CWE-79
Open these records in search →