Nagios Fusion < 4.0.1 XSS via Users/Servers Page
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Nagios Fusion versions prior to 4.0.1 are vulnerable to cross-site scripting (XSS) via the Users and Servers pages. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00516 44th percentileScored 2026-11-07
Fix Fixed Fusion (Nagios): 4.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Fusion (Nagios) Fixed in 4.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20209
- 2026-10-03 Alias added: GHSA-vcfc-84hr-mgwm
References
More Nagios Fusion vulnerabilities
- TI-2020-17439 Improper Input Validation in Nagios Fusion 4.1.8 and earlier allows an authenticated… CVSS 3.1HIGH 8.8
- TI-2020-17435 Command Injection in Nagios Fusion 4.1.8 and earlier allows for Privilege Escalation or… CVSS 3.1CRITICAL 9.8
- TI-2020-17436 Command Injection in Nagios Fusion 4.1.8 and earlier allows Privilege Escalation from apache to root in cmd_subsys.php. CVSS 3.1CRITICAL 9.8
- TI-2020-17442 Command Injection in Nagios Fusion 4.1.8 and earlier allows for Privilege Escalation to nagios. CVSS 3.1CRITICAL 9.8
- TI-2020-17438 Execution with Unnecessary Privileges in Nagios Fusion 4.1.8 and earlier allows for… CVSS 3.1CRITICAL 9.8
- TI-2020-17441 Incorrect SSL certificate validation in Nagios Fusion 4.1.8 and earlier allows for… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-20209 · CVE Program
- CVE-2017-20209 · NVD
- FIRST EPSS
- GHSA-vcfc-84hr-mgwm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences