Qualys discovered that needrestart, before version 3.8, allows local attackers to execute arbitrary code as root by tricking needrestart into running the Python interpreter with an attacker-controlled PYTHONPATH environm…
CVSS 3.1HIGH 7.8·Local·Low privileges·No interaction·EPSS 0.21269·Published 2024-11-19·Fixed in 3.8CWE-427
Qualys discovered that needrestart, before version 3.8, allows local attackers to execute arbitrary code as root by tricking needrestart into running the Ruby interpreter with an attacker-controlled RUBYLIB environment v…
CVSS 3.1HIGH 7.8·Local·Low privileges·No interaction·EPSS 0.07955·Published 2024-11-19·Fixed in 3.8CWE-427
Qualys discovered that needrestart, before version 3.8, allows local attackers to execute arbitrary code as root by winning a race condition and tricking needrestart into running their own, fake Python interpreter (inste…
CVSS 3.1HIGH 7.8·Local·Low privileges·No interaction·EPSS 0.06067·Published 2024-11-19·Fixed in 3.8CWE-362