Vendors / node-red Records 6 All Threatist records
Exploited (KEV) 0 None in CISA KEV
CVSS critical 0 CVSS 9.0–10.0
CVSS high 2 CVSS 7.0–8.9
Exploited now node-red records in CISA KEV No node-red vulnerabilities are listed in CISA KEV.
Components Products in the NVD configurations · select one to filter the records Priority MEDIUM 60
A vulnerability, which was classified as problematic, has been found in node-red-dashboard.
CVSS 3.1 MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0083 · Published 2022-10-31 · Fixed in 3.2.0 CWE-707
Priority MEDIUM 51
Node-RED-Dashboard before 2.26.2 allows ui_base/js/..%2f directory traversal to read files.
CVSS 3.1 HIGH 7.5· Network · No auth · No interaction · EPSS 0.1885 · Published 2021-01-26 · Fixed in 2.26.2 CWE-22
Priority LOW 36
Node-Red is a low-code programming for event-driven applications built using nodejs.
CVSS 3.1 HIGH 7.7· Network · Low privileges · No interaction · EPSS 0.01397 · Published 2021-02-26 · Fixed in 1.2.8 CWE-1321
Priority LOW 31
Node-Red is a low-code programming for event-driven applications built using nodejs.
CVSS 3.1 MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.0108 · Published 2021-02-26 · Fixed in 1.2.8 CWE-22
Priority LOW 25
A stored XSS vulnerability is present within node-red (version: <= 0.20.7) npm package, which is a visual tool for wiring the Internet of Things.
CVSS 3.1 MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00644 · Published 2020-01-28 · Fixed in 0.20.8 CWE-79
Priority LOW 25
It is possible to inject JavaScript within node-red-dashboard versions prior to version 2.17.0 due to the ui_notification node accepting raw HTML by default.
CVSS 3.1 MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.0057 · Published 2019-10-08 · Fixed in 2.17.0 CWE-79
Open these records in search → All records by CVSS severity
Critical0 High2 Medium4 Low0 No CVSS0