Cross-site scripting in node-red
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A stored XSS vulnerability is present within node-red (version: <= 0.20.7) npm package, which is a visual tool for wiring the Internet of Things. This issue will allow the attacker to steal session cookies, deface web applications, etc.
Why it matters now
EPSS 0.00644 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed node-red (npm): 0.20.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | node-red | up to 0.20.7 | — | No fix listed | CNA |
| — | node-red (npm) | before 0.20.8 | 0.20.8 | Patch available | GHSA-8w65-xjc5-9w79 |
- node-red Vendor— Affected up to 0.20.7 Fixed in — No fix listed CNA
- node-red (npm) Vendor— Affected before 0.20.8 Fixed in 0.20.8 Patch available GHSA-8w65-xjc5-9w79
Remediation
- Fix · GHSA-8w65-xjc5-9w79 node-red (npm) Fixed in 0.20.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15607
- 2026-10-03 Alias added: GHSA-8w65-xjc5-9w79
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
More Node-red vulnerabilities
- TI-2021-04397 Prototype Pollution in Node-Red CVSS 3.1HIGH 7.7
- TI-2021-04398 Path traversal in Node-Red CVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-15607 · CVE Program
- CVE-2019-15607 · NVD
- FIRST EPSS
- GHSA-8w65-xjc5-9w79 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences