Notepad++ versions prior to 8.8.9, when using the WinGUp updater, contain an update integrity verification vulnerability where downloaded update metadata and installers are not cryptographically verified.
CVSS 4.0HIGH 7.7·Network·No auth·User interaction·EPSS 0.01746·Published 2026-02-03·Fixed in 8.8.9CWE-494
Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary code via certain Ruby (.rb) files with long…
The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code via a Trojan horse update, as demonstrated…
Notepad++ 8.9.3 contains a format string injection vulnerability in the Find Results panel handler that allows attackers to cause denial of service and information disclosure by crafting a malicious nativeLang.xml langua…
CVSS 4.0MEDIUM 4.6·Local·No auth·User interaction·EPSS 0.00191·Published 2026-04-30·Fixed in 8.9.4CWE-134