Vulnerability in Notepad++
Priority MEDIUM 62CWE-134Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Successful exploitation of the string injection vulnerability could allow an attacker to obtain memory address information or crash the application.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00224 13th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3008
- 2026-10-03 Alias added: GHSA-v6h7-975g-34x5
References
Other 5
More Notepad++ vulnerabilities
- TI-2025-14195 Notepad++ < 8.8.9 WinGUp Updater Lacks Update Integrity Verification KEVCVSS 4.0HIGH 7.7
- TI-2007-02577 Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by… CVSS 2.0HIGH 7.6
- TI-2008-03296 The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the… CVSS 2.0HIGH 7.5
- TI-2026-05734 Notepad++ 8.9.3 Format String Injection via nativeLang.xml CVSS 4.0MEDIUM 4.6
Sources
- CVE-2026-3008 · CVE Program
- CVE-2026-3008 · NVD
- FIRST EPSS
- GHSA-v6h7-975g-34x5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences