Read the docs

ollama

Records30All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high23CVSS 7.0–8.9

Exploited now

ollama records in CISA KEV

No ollama vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

30 records

Priority HIGH 81

Ollama before 0.1.34 does not validate the format of the digest (sha256 with 64 hex digits) when getting the model path, and thus mishandles the TestGetBlobsPath test cases such as fewer than 64 hex digits, more than 64…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.89633 Published 2024-05-31 Fixed in 0.1.34 CWE-22
Priority HIGH 77

Ollama 0.11.5-rc0 through current version 0.13.5 contain a null pointer dereference vulnerability in the multi-modal model image processing functionality.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00765 Published 2026-01-12 Will not fix CWE-395
Priority HIGH 72

A vulnerability in the Ollama server version 0.5.11 allows a malicious user to cause a Denial of Service (DoS) attack by customizing the manifest content and spoofing a service.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.00517 Published 2025-05-16 No fix listed CWE-129
TI-2025-00256 CVE-2025-0317 · GHSA-9gcr-28rp-cc24

Divide By Zero in ollama/ollama

Priority HIGH 72

A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to upload and create a customized GGUF model file on the Ollama server.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.14501 Published 2025-03-20 No fix listed CWE-369
TI-2025-00252 CVE-2025-0312 · GHSA-p2wh-w96x-w232

NULL Pointer Dereference in ollama/ollama

Priority HIGH 72

A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer d…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00644 Published 2025-03-20 No fix listed CWE-476
Priority HIGH 72

An Out-Of-Memory (OOM) vulnerability exists in the `ollama` server version 0.3.14.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.00733 Published 2025-03-20 No fix listed CWE-409
Priority HIGH 72

A vulnerability in Ollama versions <=0.3.14 allows a malicious user to create a customized gguf model file that can be uploaded to the public Ollama server.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00817 Published 2025-03-20 No fix listed CWE-125
TI-2024-07476 CVE-2024-8063 · GHSA-2xf2-gjm6-g2c6

Divide by Zero in ollama/ollama

Priority HIGH 72

A divide by zero vulnerability exists in ollama/ollama version v0.3.3.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00643 Published 2025-03-20 No fix listed CWE-369
Priority MEDIUM 64

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header…

CVSS 3.1MEDIUM 6.9 Network No auth User interaction EPSS 0.18528 Published 2025-07-22 No fix listed CWE-345
Priority MEDIUM 45

Ollama (HEAD f0078ae) contains an uncontrolled memory allocation vulnerability in the GGUF metadata parser that allows remote attackers to crash the server by supplying a crafted GGUF file with attacker-controlled length…

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00807 Published 2026-07-21 Will not fix CWE-789
Priority MEDIUM 44

Ollama is vulnerable to path traversal in the `/api/pull` endpoint due to insufficient validation of layer digests by the `digestToPath` function.

CVSS 4.0CRITICAL 9.4 Network No auth User interaction EPSS 0.00714 Published 2026-10-08 Fixed in 0.35.0 CWE-23
Priority MEDIUM 44

Ollama fails to validate redirect destinations when pulling tensor-layer models, allowing unauthenticated attackers to redirect blob downloads to arbitrary hosts.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00497 Published 2026-09-03 No fix listed CWE-918
TI-2026-13197 CVE-2026-15685 · GHSA-c7vp-gjfc-x6p8

Improper array index validation in Ollama

Priority MEDIUM 40

Ollama downloadBlob Improper Validation of Array Index Denial-of-Service Vulnerability.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.00715 Published 2026-07-13 No fix listed CWE-129
Load more
Open these records in search →