extractFromZipFile in model.go in Ollama before 0.1.47 can extract members of a ZIP…
Priority MEDIUM 52CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
extractFromZipFile in model.go in Ollama before 0.1.47 can extract members of a ZIP archive outside of the parent directory.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0256 85th percentileScored 2026-11-07
Fix Fixed github.com/ollama/ollama (Go): 0.1.47
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/ollama/ollama (Go) | before 0.1.47 | 0.1.47 | Patch available | GHSA-846m-99qv-67mg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/ollama/ollama (Go) Vendor— Affected before 0.1.47 Fixed in 0.1.47 Patch available GHSA-846m-99qv-67mg
Remediation
- Fix · GHSA-846m-99qv-67mg github.com/ollama/ollama (Go) Fixed in 0.1.47 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45436
- 2026-10-03 Alias added: GHSA-846m-99qv-67mg
References
More Ollama vulnerabilities
- TI-2024-24572 Ollama before 0.1.34 does not validate the format of the digest (sha256 with 64 hex… CVSS 3.1HIGH 8.8
- TI-2025-14153 Ollama Multi-Modal Model Image Processing NULL Pointer Dereference CVSS 4.0HIGH 8.7
- TI-2024-26641 An issue was discovered in Ollama before 0.1.46. CVSS 3.1HIGH 8.2
- TI-2025-41098 An issue in ollama v.0.12.10 allows a remote attacker to cause a denial of service via… CVSS 3.1HIGH 7.5
- TI-2025-41097 An issue in ollama v.0.12.10 allows a remote attacker to cause a denial of service via the GGUF decoder CVSS 3.1HIGH 7.5
- TI-2025-01720 Improper Validation of Array Index in ollama/ollama CVSS 3.0HIGH 7.5
Sources
- CVE-2024-45436 · CVE Program
- CVE-2024-45436 · NVD
- FIRST EPSS
- GHSA-846m-99qv-67mg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences