Read the docs

openwrt

Records169All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical17CVSS 9.0–10.0
CVSS high50CVSS 7.0–8.9

Exploited now

openwrt records in CISA KEV

No openwrt vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

169 records

Priority HIGH 77

odhcpd is the DHCPv6, DHCPv4, and router-advertisement server used by OpenWrt.

CVSS 4.0HIGH 8.8 Network No auth No interaction EPSS 0.00619 Published 2026-10-23 Fixed in 25.12 CWE-416
Priority HIGH 77

OpenWrt luci-app-bmx7 before commit 5890760a454dad2cb00389dba2cdc5e779e0ffdd contains a path traversal vulnerability in the bmx7-info CGI script that allows unauthenticated attackers to read files outside the configured…

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00928 Published 2026-08-03 Fixed CWE-22
Priority HIGH 77

luci-app-banip contains a log parsing vulnerability where the awk-based parser extracts the first IPv4 address from log lines regardless of field position, allowing attackers to inject arbitrary IPs via attacker-controll…

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00556 Published 2026-07-13 Fixed CWE-116
Priority HIGH 76

luci-app-openvpn fails to properly validate the instance_name2 parameter during file upload, allowing authenticated users to perform path traversal and write arbitrary files outside the intended directory.

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00616 Published 2026-08-13 Fixed in 24.10.7, 25.12.4 CWE-73
Priority HIGH 76

OpenWrt is a Linux operating system targeting embedded devices.

CVSS 3.1CRITICAL 9.6 Network No auth User interaction EPSS 0.0058 Published 2026-07-15 Fixed in 25.12.5 CWE-117
Priority HIGH 76

LuCI versions fail to properly encode DHCPv6 lease hostnames before rendering in status tables, allowing adjacent network attackers to inject HTML markup.

CVSS 4.0CRITICAL 9.4 Adjacent network No auth User interaction EPSS 0.01621 Published 2026-07-12 No fix listed CWE-79
Priority HIGH 73

OpenWrt LuCI contains an overly permissive ACL definition in luci-mod-system-mounts that grants write access to /etc/crontabs/root to users intended only for mount configuration.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00442 Published 2026-08-13 No fix listed CWE-266
Priority HIGH 73

luci-app-upnp contains a stored cross-site scripting vulnerability that allows unauthenticated LAN clients to inject JavaScript via UPnP IGD AddPortMapping SOAP requests.

CVSS 4.0HIGH 8.7 Network No auth User interaction EPSS 0.00358 Published 2026-07-12 Fixed in 24.10.8, 25.12.5 CWE-79
Priority HIGH 73

OpenWrt luci-app-samba4 read ACL grants file.exec permission on /usr/sbin/smbd, allowing authenticated delegated users to execute the Samba daemon with caller-controlled command-line arguments.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00875 Published 2026-07-12 Fixed in 24.10.8, 25.12.5 CWE-269
Priority HIGH 73

luci-proto-openvpn through 0.11.1, fixed in commit e4ff45e, contains a command injection vulnerability in the generateKey ubus method where the cl_meta parameter is interpolated into a shell command without proper escapi…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.01723 Published 2026-06-29 Fixed CWE-78
Priority HIGH 69

luci-app-travelmate (and the travelmate package) contain a privilege-escalation flaw: a LuCI/rpcd session holding the luci-app-travelmate write ACL is granted config-wide UCI write access to the travelmate configuration.

CVSS 4.0HIGH 7.7 Network Low privileges No interaction EPSS 0.00672 Published 2026-07-02 Fixed in 2.4.6-2 CWE-78
Priority HIGH 69

luci-app-tailscale-community contains a command injection vulnerability in the tailscale.do_login RPC method that allows authenticated users to execute arbitrary commands as root.

CVSS 4.0HIGH 7.7 Network Low privileges No interaction EPSS 0.01475 Published 2026-06-29 No fix listed CWE-78
Priority MEDIUM 64

luci-lib-px5g (LuCI) contains a heap-based buffer overflow in the native ASN.1 encoding routine asn1_add_obj (x509write.c) when signing a certificate with a 2040-bit RSA key.

CVSS 4.0MEDIUM 6.9 Local Low privileges No interaction EPSS 0.00108 Published 2026-08-22 No fix listed CWE-122
Priority MEDIUM 56

luci-app-adblock-fast before 1.2.4-4 contains a stored cross-site scripting vulnerability in the blocklist name field that allows lower-privileged users to inject active HTML.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00235 Published 2026-08-02 Fixed in 1.2.4-4 CWE-79
Load more
Open these records in search →