Priority HIGH 82
A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary system commands.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0312 · Published 2023-08-09 · No fix listed CWE-77
Priority HIGH 82
Insecure permissions in the configuration directory (/conf/) of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allow attackers to access sensitive information (e.g., hashed root password) which…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00986 · Published 2023-08-09 · No fix listed CWE-732
Priority HIGH 82
A command injection vulnerability in the component diag_backup.php of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary commands via a crafted backup configur…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03627 · Published 2023-08-09 · No fix listed CWE-77
Priority HIGH 82
DECISO OPNsense 23.1 does not impose rate limits for authentication, allowing attackers to perform a brute-force attack to bypass authentication.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01107 · Published 2023-10-23 · No fix listed CWE-307
Priority HIGH 76
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.00858 · Published 2026-10-15 · Fixed in 26.1.11 CWE-22
Priority HIGH 76
/ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows XSS via openAction in app/controllers/OPNsense/Cron/ItemController.php.
CVSS 3.1CRITICAL 9.6· Network · No auth · User interaction · EPSS 0.02608 · Published 2023-08-09 · No fix listed CWE-79
Priority HIGH 75
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.00423 · Published 2026-04-09 · Fixed in 26.1.6 CWE-90
Priority HIGH 74
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1CRITICAL 9.1· Network · High privileges · No interaction · EPSS 0.05673 · Published 2026-05-13 · Fixed in 26.1.8 CWE-78
Priority HIGH 74
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1CRITICAL 9.1· Network · High privileges · No interaction · EPSS 0.00686 · Published 2026-05-13 · Fixed in 26.1.7 CWE-88
Priority HIGH 74
OPNsense before 25.1.8 contains an authenticated command injection vulnerability in its Bridge Interface Edit endpoint (interfaces_bridge_edit.php).
CVSS 3.1CRITICAL 9.1· Network · High privileges · No interaction · EPSS 0.1093 · Published 2025-08-27 · Fixed in 25.1.8 CWE-78
Priority HIGH 72
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1CRITICAL 9.0· Network · High privileges · No interaction · EPSS 0.00473 · Published 2026-09-08 · Fixed in 26.1.9, 26.4_20 CWE-22
Priority HIGH 72
Insecure permissions exist for configd.socket in OPNsense Community Edition before 23.7 and Business Edition before 23.4.2.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00719 · Published 2023-08-09 · No fix listed CWE-732
Priority HIGH 72
OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 was discovered to contain insecure permissions in the directory /tmp.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00789 · Published 2023-08-09 · No fix listed CWE-732
Priority HIGH 70
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.00604 · Published 2026-10-15 · Fixed in 26.1.11 CWE-79
Priority HIGH 68
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.0046 · Published 2026-11-03 · Fixed in 26.1.11 CWE-74
Priority HIGH 68
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00318 · Published 2026-05-13 · Fixed in 26.1.7 CWE-307
Priority HIGH 68
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1HIGH 8.1· Network · No auth · User interaction · EPSS 0.0017 · Published 2026-03-11 · Fixed in 26.1.4 CWE-352
Priority MEDIUM 64
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.0038 · Published 2026-10-15 · Fixed in 26.1.11 CWE-863
Priority MEDIUM 62
A Cross-Site Request Forgery (CSRF) in the System Halt API (/system/halt) of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to cause a Denial of Service (DoS) via a crafted GET…
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00397 · Published 2023-08-09 · No fix listed CWE-352
Priority MEDIUM 62
OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject malicious scripts by submitting crafted payloads through the ignoreLogACL parameter.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.0042 · Published 2026-02-15 · No fix listed CWE-79
Priority MEDIUM 62
OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject malicious scripts by submitting crafted input to the mailserver parameter.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00416 · Published 2026-02-15 · No fix listed CWE-79
Priority MEDIUM 62
OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows attackers to inject malicious scripts by exploiting the passthrough_networks parameter in vpn_ipsec_settings.php.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00368 · Published 2026-02-15 · No fix listed CWE-79
Priority MEDIUM 60
OPNsense is a FreeBSD based firewall and routing platform.
CVSS 3.1MEDIUM 5.9· Network · Low privileges · No interaction · EPSS 0.00433 · Published 2026-10-15 · Fixed in 26.1.11 CWE-22
Priority MEDIUM 60
A cross-site scripting (XSS) vulnerability in the act parameter of system_certmanager.php in OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary web scripts or…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01202 · Published 2023-08-09 · No fix listed CWE-79
Priority MEDIUM 60
A reflected cross-site scripting (XSS) vulnerability in the component /ui/diagnostics/log/core/ of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to inject arbitrary JavaScript…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00572 · Published 2023-08-09 · No fix listed CWE-79
Load more