Read the docs

opnsense

Records55All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical12CVSS 9.0–10.0
CVSS high12CVSS 7.0–8.9

Exploited now

opnsense records in CISA KEV

No opnsense vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

36 records in Opnsense · all components

Priority HIGH 82

Insecure permissions in the configuration directory (/conf/) of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allow attackers to access sensitive information (e.g., hashed root password) which…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00986 Published 2023-08-09 No fix listed CWE-732
Priority HIGH 82

A command injection vulnerability in the component diag_backup.php of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary commands via a crafted backup configur…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03627 Published 2023-08-09 No fix listed CWE-77
Priority HIGH 74

OPNsense is a FreeBSD based firewall and routing platform.

CVSS 3.1CRITICAL 9.1 Network High privileges No interaction EPSS 0.05673 Published 2026-05-13 Fixed in 26.1.8 CWE-78
TI-2025-32291 CVE-2025-50989 · GHSA-qf7f-cgq3-xfvh

OS command injection in OPNsense

Priority HIGH 74

OPNsense before 25.1.8 contains an authenticated command injection vulnerability in its Bridge Interface Edit endpoint (interfaces_bridge_edit.php).

CVSS 3.1CRITICAL 9.1 Network High privileges No interaction EPSS 0.1093 Published 2025-08-27 Fixed in 25.1.8 CWE-78
Priority HIGH 68

OPNsense is a FreeBSD based firewall and routing platform.

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00318 Published 2026-05-13 Fixed in 26.1.7 CWE-307
Priority MEDIUM 62

A Cross-Site Request Forgery (CSRF) in the System Halt API (/system/halt) of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to cause a Denial of Service (DoS) via a crafted GET…

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00397 Published 2023-08-09 No fix listed CWE-352
Priority MEDIUM 62

OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject malicious scripts by submitting crafted payloads through the ignoreLogACL parameter.

CVSS 4.0MEDIUM 5.1 Network No auth User interaction EPSS 0.0042 Published 2026-02-15 No fix listed CWE-79
Priority MEDIUM 62

OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject malicious scripts by submitting crafted input to the mailserver parameter.

CVSS 4.0MEDIUM 5.1 Network No auth User interaction EPSS 0.00416 Published 2026-02-15 No fix listed CWE-79
Priority MEDIUM 62

OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows attackers to inject malicious scripts by exploiting the passthrough_networks parameter in vpn_ipsec_settings.php.

CVSS 4.0MEDIUM 5.1 Network No auth User interaction EPSS 0.00368 Published 2026-02-15 No fix listed CWE-79
Priority MEDIUM 60

A cross-site scripting (XSS) vulnerability in the act parameter of system_certmanager.php in OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary web scripts or…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01202 Published 2023-08-09 No fix listed CWE-79
Priority MEDIUM 60

A reflected cross-site scripting (XSS) vulnerability in the component /ui/diagnostics/log/core/ of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to inject arbitrary JavaScript…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00572 Published 2023-08-09 No fix listed CWE-79
Priority MEDIUM 56

OPNsense 19.1 contains a stored cross-site scripting vulnerability that allows authenticated attackers to inject malicious scripts by submitting crafted input to the category parameter.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00238 Published 2026-02-15 No fix listed CWE-79
Priority MEDIUM 56

OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject malicious scripts by exploiting insufficient input validation in the host parameter.

CVSS 4.0MEDIUM 5.1 Network No auth User interaction EPSS 0.00287 Published 2026-02-15 No fix listed CWE-79
Load more
Open these records in search →