Priority HIGH 67
The All-in-One Video Gallery plugin for WordPress is vulnerable to arbitrary file downloads and blind server-side request forgery via the 'dl' parameter found in the ~/public/video.php file in versions up to, and includi…
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.35707 · Published 2022-09-06 · No fix listed CWE-610
Priority MEDIUM 43
The All-in-One Video Gallery plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the aiovg_create_attachment_from_external_image_url function in all versions up to, and inc…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01558 · Published 2024-05-02 · No fix listed CWE-434
Priority MEDIUM 41
The All-in-One Video Gallery plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the resolve_import_directory() function in versions 4.5.4 to 4.5.7.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00557 · Published 2025-12-06 · No fix listed CWE-434
Priority MEDIUM 41
The All-in-One Video Gallery plugin for WordPress is vulnerable to arbitrary file upload in all versions up to, and including, 4.5.7.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0065 · Published 2026-01-16 · No fix listed CWE-434
Priority MEDIUM 41
The All-in-One Video Gallery plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.6.5 via the aiovg_search_form shortcode.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00618 · Published 2024-05-15 · No fix listed CWE-98
Priority MEDIUM 40
The All-in-One Video Gallery WordPress plugin before 2.5.0 does not sanitise and validate the tab parameter before using it in a require statement in the admin dashboard, leading to a Local File Inclusion issue
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.05013 · Published 2021-12-13 · Fixed in 2.5.0 CWE-22
Priority LOW 38
Missing Authorization vulnerability in Team Plugins360 All-in-One Video Gallery.This issue affects All-in-One Video Gallery: from n/a through 3.5.2.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00376 · Published 2024-06-09 · No fix listed CWE-862
Priority LOW 35
The All-in-One Video Gallery plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `ajax_callback_create_bunny_stream_video`, `ajax_callback_get_bunny_stream_vid…
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00401 · Published 2026-01-23 · No fix listed CWE-862
Priority LOW 29
The All-in-One Video Gallery plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.8.5 via the 'vdl' parameter.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00418 · Published 2026-07-10 · No fix listed CWE-918
Priority LOW 28
The All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo & Self-Hosted Videos plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'custom_fields[].value.label (for key='t…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00252 · Published 2026-11-06 · No fix listed CWE-79
Priority LOW 28
The All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo & Self-Hosted Videos plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'more_link' parameter in all versions up to, and i…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00193 · Published 2026-10-28 · No fix listed CWE-79
Priority LOW 28
The All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo & Self-Hosted Videos plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'custom_fields[embedcode]' parameter in all versio…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00207 · Published 2026-10-28 · No fix listed CWE-79
Priority LOW 28
The All-in-One Video Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Video shortcode in all versions up to, and including, 3.7.1 due to insufficient input sanitization and outpu…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00329 · Published 2024-07-24 · No fix listed CWE-79
Priority LOW 28
The Freemius SDK, as used by hundreds of WordPress plugin and theme developers, was vulnerable to Cross-Site Request Forgery and Information disclosure due to missing capability checks and nonce protection on the _get_de…
CVSS 3.1MEDIUM 6.3· Network · Low privileges · No interaction · EPSS 0.00442 · Published 2024-10-16 · Fixed in 2.0.2, 1.9.8 +273 CWE-862
Priority LOW 27
The All-in-One Video Gallery plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'vi' parameter in all versions up to, and including, 4.7.1 due to insufficient input sanitization and output escap…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00269 · Published 2026-03-04 · No fix listed CWE-79
Priority LOW 27
Multiple plugins and/or themes for WordPress are vulnerable to Reflected Cross-Site Scripting via the url parameter in various versions due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00276 · Published 2026-05-01 · No fix listed CWE-79
Priority LOW 19
The All-in-One Video Gallery plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_callback_store_user_meta() function in versions 4.1.0 to 4.6.4.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00188 · Published 2026-01-24 · No fix listed CWE-862