All-In-One-Gallery < 2.5.0 - Admin+ Local File Inclusion
Priority MEDIUM 40CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The All-in-One Video Gallery WordPress plugin before 2.5.0 does not sanitise and validate the tab parameter before using it in a require statement in the admin dashboard, leading to a Local File Inclusion issue
Why it matters now
EPSS 0.05013 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed All-in-One Video Gallery (Unknown): 2.5.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | All-in-One Video Gallery | 2.5.0 to before 2.5.0 | 2.5.0 | Patch available | CNA |
- All-in-One Video Gallery VendorUnknown Affected 2.5.0 to before 2.5.0 Fixed in 2.5.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plugins360:all-in-one_video_gallery:*:*:*:*:*:wordpress:*:* | before 2.5.0 | Vulnerable | plugins360 |
- cpe:2.3:a:plugins360:all-in-one_video_gallery:*:*:*:*:*:wordpress:*:* Versions before 2.5.0 Vulnerable ·plugins360
Remediation
- Fix · CNA All-in-One Video Gallery (Unknown) Fixed in 2.5.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24970
- 2026-10-03 Alias added: GHSA-c9pf-3r6r-m8r5
References
More plugins360 All-in-one Video Gallery vulnerabilities
- TI-2022-02434 The All-in-One Video Gallery plugin for WordPress is vulnerable to arbitrary file… CVSS 3.1HIGH 8.2
- TI-2024-20624 WordPress All-in-One Video Gallery plugin <= 3.5.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-06147 All-in-One Video Gallery <= 3.7.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Video Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24970 · CVE Program
- CVE-2021-24970 · NVD
- FIRST EPSS
- GHSA-c9pf-3r6r-m8r5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences