Vendors / Post Snippets Records 3 All Threatist records
Exploited (KEV) 0 None in CISA KEV
CVSS critical 1 CVSS 9.0–10.0
CVSS high 1 CVSS 7.0–8.9
Exploited now Post Snippets records in CISA KEV No Post Snippets vulnerabilities are listed in CISA KEV.
Components Products in the NVD configurations · select one to filter the records Priority MEDIUM 42
The Post Snippets WordPress plugin before 3.1.4 does not have CSRF check when importing files, allowing attacker to make a logged In admin import arbitrary snippets.
CVSS 3.1 CRITICAL 9.6· Network · No auth · User interaction · EPSS 0.00612 · Published 2022-02-28 · Fixed in 3.1.4 CWE-352
Priority MEDIUM 40
Contributor Remote Code Execution (RCE) in Post Snippets <= 4.0.19 versions.
CVSS 3.1 HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00582 · Published 2026-06-25 · No fix listed CWE-94
Priority LOW 27
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Postsnippets Post Snippets plugin <= 4.0.2 versions.
CVSS 3.1 MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.00396 · Published 2023-08-08 · No fix listed CWE-79
Open these records in search → All records by CVSS severity
Critical1 High1 Medium1 Low0 No CVSS0