Read the docs
TI-2021-07288 Aliases CVE-2021-25010GHSA-x3f9-wfr9-6xw8

Post Snippets < 3.1.4 - CSRF to Stored Cross-Site Scripting

Priority MEDIUM 42CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The Post Snippets WordPress plugin before 3.1.4 does not have CSRF check when importing files, allowing attacker to make a logged In admin import arbitrary snippets. Furthermore, imported snippers are not sanitised and escaped, which could lead to Stored Cross-Site Scripting issues

Why it matters now

EPSS 0.00612 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Post Snippets (Unknown): 3.1.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPost Snippets3.1.4 to before 3.1.43.1.4Patch availableCNA
  • Post Snippets VendorUnknown Affected 3.1.4 to before 3.1.4 Fixed in 3.1.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:postsnippets:post_snippets:*:*:*:*:*:wordpress:*:*before 3.1.4VulnerablePost Snippets
  • cpe:2.3:a:postsnippets:post_snippets:*:*:*:*:*:wordpress:*:* Versions before 3.1.4 Vulnerable ·Post Snippets

Remediation

  • Fix · CNA Post Snippets (Unknown) Fixed in 3.1.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25010
  2. 2026-10-03 Alias added: GHSA-x3f9-wfr9-6xw8

References

  • TI-2023-10769 WordPress Post Snippets Plugin <= 4.0.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources