Read the docs

Pulse Secure

Records94All Threatist records
Exploited (KEV)3In CISA KEV
CVSS critical8CVSS 9.0–10.0
CVSS high47CVSS 7.0–8.9

Exploited now

Pulse Secure records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

94 records

TI-2021-05761 CVE-2021-22900 · GHSA-j8cw-m86f-rxgw

Code injection in Pulse Secure Secure

Priority CRITICAL 91KEV

A vulnerability allowed multiple unrestricted uploads in Pulse Connect Secure before 9.1R11.4 that could lead to an authenticated administrator to perform a file write via a maliciously crafted archive upload in the admi…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.14146 Published 2021-05-27 No fix listed CWE-94
TI-2020-06636 CVE-2020-8218 · GHSA-29h7-cpmq-mh8j

Code injection in Pulse Connect Secure

Priority CRITICAL 91KEV

A code injection vulnerability exists in Pulse Connect Secure <9.1R8 that allows an attacker to crafted a URI to perform an arbitrary code execution via the admin web interface.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.3225 Published 2020-07-30 No fix listed CWE-94
Priority CRITICAL 91KEV

In Pulse Secure Pulse Connect Secure version 9.0RX before 9.0R3.4, 8.3RX before 8.3R7.1, 8.2RX before 8.2R12.1, and 8.1RX before 8.1R15.1 and Pulse Policy Secure version 9.0RX before 9.0R3.2, 5.4RX before 5.4R7.1, 5.3RX…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.98544 Published 2019-04-26 No fix listed CWE-78
Priority HIGH 78

Jonathan Looney discovered that the TCP_SKB_CB(skb)->tcp_gso_segs value was subject to an integer overflow in the Linux kernel when handling TCP Selective Acknowledgments (SACKs).

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.98745 Published 2019-06-18 Fixed in 4.4.182, 4.9.182 +3 CWE-190
Priority HIGH 77

Jonathan Looney discovered that the TCP retransmission queue implementation in tcp_fragment in the Linux kernel could be fragmented when handling certain TCP Selective Acknowledgment (SACK) sequences.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.94414 Published 2019-06-18 Partial fix · 4.4.182, 4.9.182 +3 CWE-770
TI-2021-05769 CVE-2021-22908 · GHSA-37f5-2q74-7wvc

Buffer overflow in Pulse Connect Secure

Priority HIGH 75

A buffer overflow vulnerability exists in Windows File Resource Profiles in 9.X allows a remote authenticated user with privileges to browse SMB shares to execute arbitrary code as the root user.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.69377 Published 2021-05-27 No fix listed CWE-120
Priority HIGH 68

In Pulse Secure Pulse Connect Secure version 9.0RX before 9.0R3.4, 8.3RX before 8.3R7.1, 8.2RX before 8.2R12.1, and 8.1RX before 8.1R15.1 and Pulse Policy Secure version 9.0RX before 9.0R3.2, 5.4RX before 5.4R7.1, 5.3RX…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.6559 Published 2019-04-26 No fix listed CWE-787
Priority HIGH 66

A time-of-check time-of-use vulnerability in PulseSecureService.exe in Pulse Secure Client versions prior to 9.1.6 down to 5.3 R70 for Windows (which runs as NT AUTHORITY/SYSTEM) allows unprivileged users to run a Micros…

CVSS 3.1HIGH 7.0 Local Low privileges No interaction EPSS 0.00793 Published 2020-06-16 No fix listed CWE-367
Priority MEDIUM 56

A vulnerability in the Pulse Connect Secure < 9.1R8.2 admin web interface could allow an authenticated attacker to gain arbitrary file reading access through Pulse Collaboration via XML External Entity (XXE) vulnerabilit…

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.03356 Published 2020-09-29 No fix listed CWE-611
Priority MEDIUM 54

Pulse Secure version 9.115 and below may be susceptible to client-side http request smuggling, When the application receives a POST request, it ignores the request's Content-Length header and leaves the POST body on the…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.46016 Published 2022-09-30 No fix listed CWE-444
Priority MEDIUM 53

In Pulse Secure Pulse Connect Secure version 9.0RX before 9.0R3.4 and 8.3RX before 8.3R7.1 and Pulse Policy Secure version 9.0RX before 9.0R3.2 and 5.4RX before 5.4R7.1, an unauthenticated, remote attacker can conduct a…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.07741 Published 2019-04-26 No fix listed
Priority MEDIUM 49

A vulnerability has been discovered in login.cgi in Pulse Secure Pulse Connect Secure (PCS) 8.1RX before 8.1R12 and 8.3RX before 8.3R2 and Pulse Policy Secure (PPS) 5.2RX before 5.2R9 and 5.4RX before 5.4R2 wherein an ht…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.04079 Published 2018-09-06 No fix listed CWE-20
Priority MEDIUM 48

A stack-based Buffer Overflow Vulnerability exists in the web server in Pulse Secure Pulse Connect Secure (PCS) before 8.3R4 and Pulse Policy Secure (PPS) before 5.4R4, leading to memory corruption and possibly remote co…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.03061 Published 2018-01-16 No fix listed CWE-787
Priority MEDIUM 48

Pulse Connect Secure (PCS) 8.2 before 8.2r1, 8.1 before 8.1r2, 8.0 before 8.0r10, and 7.4 before 7.4r13.4 allow remote attackers to read sensitive system authentication files in an unspecified directory via unknown vecto…

CVSS 3.0CRITICAL 10.0 Network No auth No interaction EPSS 0.02487 Published 2016-05-26 No fix listed
Priority MEDIUM 47

In Pulse Secure Pulse Connect Secure (PCS) before 8.1R15.1, 8.2 before 8.2R12.1, 8.3 before 8.3R7.1, and 9.0 before 9.0R3.4, an authenticated attacker (via the admin web interface) can exploit Directory Traversal to exec…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.1469 Published 2019-05-08 No fix listed CWE-22
Priority MEDIUM 42

A vulnerability in Pulse Connect Secure before 9.1R12 could allow an authenticated administrator to perform a file write via a maliciously crafted archive uploaded in the administrator web interface.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.07828 Published 2021-08-16 No fix listed CWE-434
Priority MEDIUM 42

A vulnerability in the Pulse Secure Desktop Client < 9.1R9 has Remote Code Execution (RCE) if users can be convinced to connect to a malicious server.

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.02123 Published 2020-10-28 No fix listed CWE-23
Load more
Open these records in search →