Read the docs

ruby

Records136All Threatist records
Exploited (KEV)1In CISA KEV
CVSS critical18CVSS 9.0–10.0
CVSS high49CVSS 7.0–8.9

Exploited now

ruby records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

5 records in Cgi · all components

Priority MEDIUM 50

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.04898 Published 2022-02-06 Fixed in 0.3.1, 0.2.1 +1 CWE-190
Priority LOW 34

In the CGI gem before 0.4.2 for Ruby, a Regular Expression Denial of Service (ReDoS) vulnerability exists in the Util#escapeElement method.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0076 Published 2025-03-03 Partial fix · 0.3.5.1, 0.3.7 +1 CWE-1333
Priority LOW 34

In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00849 Published 2025-03-03 Partial fix · 0.3.5.1, 0.3.7 +1 CWE-770
Open these records in search →