Priority CRITICAL 100KEV
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to exec…
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.6522 · Published 2026-10-13 · Partial fix · 19.2.8, 19.3.5 +1 CWE-190
Priority HIGH 76
Ruby before 2.4.3 allows Net::FTP command injection.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.73829 · Published 2017-12-15 · Partial fix CWE-78
Priority HIGH 71
Algorithmic complexity vulnerability in the WEBrick::HTTPUtils.split_header_value function in WEBrick::HTTP::DefaultFileHandler in WEBrick in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and…
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.70202 · Published 2008-08-13 · Fixed CWE-399
Priority HIGH 67
In Ruby through 3.0 on Windows, a remote attacker can submit a crafted path when a Web application handles a parameter with TmpDir.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.58039 · Published 2021-07-27 · Fixed in 0.1.2 CWE-22
Priority MEDIUM 56
Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentati…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.34968 · Published 2013-11-23 · Partial fix CWE-119
Priority MEDIUM 55
An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.10715 · Published 2018-11-16 · Partial fix · 2.0.9, 2.1.2
Priority MEDIUM 55
The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute ar…
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.16412 · Published 2017-09-19 · Partial fix · 1.4.0 CWE-287
Priority MEDIUM 54
Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.09445 · Published 2017-08-31 · Partial fix CWE-119
Priority MEDIUM 52
In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.09982 · Published 2018-04-03 · Partial fix CWE-22
Priority MEDIUM 51
The lazy_initialize function in lib/resolv.rb in Ruby through 2.4.3 uses Kernel#open, which might allow Command Injection attacks, as demonstrated by a Resolv::Hosts::new argument beginning with a '|' character, a differ…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05913 · Published 2017-12-20 · Partial fix CWE-74
Priority MEDIUM 51
Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.09718 · Published 2017-09-15 · Partial fix CWE-134
Priority MEDIUM 51
Type confusion exists in _cancel_eval Ruby's TclTkIp class method.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.06153 · Published 2017-01-06 · Will not fix
Priority MEDIUM 50
An exploitable heap overflow vulnerability exists in the Fiddle::Function.new "initialize" function functionality of Ruby.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05144 · Published 2017-01-06 · Will not fix CWE-119
Priority MEDIUM 50
An exploitable heap overflow vulnerability exists in the Psych::Emitter start_document function of Ruby.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04741 · Published 2020-02-14 · Will not fix CWE-787
Priority MEDIUM 50
Multiple integer overflows in the rb_ary_store function in Ruby 1.8.4 and earlier, 1.8.5 before 1.8.5-p231, 1.8.6 before 1.8.6-p230, and 1.8.7 before 1.8.7-p22 allow context-dependent attackers to execute arbitrary code…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.04456 · Published 2008-06-24 · Fixed CWE-190
Priority MEDIUM 50
Multiple integer overflows in the rb_str_buf_append function in Ruby 1.8.4 and earlier, 1.8.5 before 1.8.5-p231, 1.8.6 before 1.8.6-p230, 1.8.7 before 1.8.7-p22, and 1.9.0 before 1.9.0-2 allow context-dependent attackers…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.04264 · Published 2008-06-24 · Fixed CWE-189
Priority MEDIUM 49
Heap-based buffer overflow in the rb_str_justify function in string.c in Ruby 1.9.1 before 1.9.1-p376 allows context-dependent attackers to execute arbitrary code via unspecified vectors involving (1) String#ljust, (2) S…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.03875 · Published 2009-12-11 · No fix listed CWE-119
Priority MEDIUM 49
httputils.rb in WEBrick in Ruby 1.8.1 and 1.8.5, as used in Red Hat Enterprise Linux 4 and 5, allows remote attackers to cause a denial of service (CPU consumption) via a crafted HTTP request.
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.13553 · Published 2008-12-09 · Fixed in 1.3.1 CWE-399
Priority MEDIUM 48
A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03138 · Published 2022-05-09 · Fixed CWE-415
Priority MEDIUM 48
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0308 · Published 2017-05-24 · Partial fix CWE-787
Priority MEDIUM 48
Type confusion exists in two methods of Ruby's WIN32OLE class, ole_invoke and ole_query_interface.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03355 · Published 2017-01-06 · No fix listed
Priority MEDIUM 48
The dl module in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not check "taintness" of inputs, which allows context-dependent attackers to bypass safe levels and…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.13666 · Published 2008-08-13 · Fixed CWE-20
Priority MEDIUM 48
Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not properly restrict access to critical variables and methods at various safe levels, which allows context-dependent…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.14085 · Published 2008-08-13 · Fixed CWE-264
Priority MEDIUM 47
The OpenSSL extension of Ruby (Git trunk) versions after 2011-09-01 up to 2011-11-03 always generated an exponent value of '1' to be used for private RSA key generation.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02529 · Published 2019-11-26 · No fix listed CWE-326
Priority MEDIUM 46
An issue was discovered in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3.
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.07968 · Published 2018-11-16 · Partial fix
Load more