Read the docs

rubygems

Records37All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical5CVSS 9.0–10.0
CVSS high21CVSS 7.0–8.9

Exploited now

rubygems records in CISA KEV

No rubygems vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

37 records

Priority MEDIUM 58

RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.15853 Published 2017-10-11 Fixed in 2.6.14 CWE-502
TI-2017-00849 CVE-2017-0901 · GHSA-pm9x-4392-2c2p

Path traversal in HackerOne RubyGems

Priority MEDIUM 56

RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.29442 Published 2017-08-31 Partial fix · 2.6.13 CWE-22
TI-2017-00847 CVE-2017-0899 · GHSA-7gcp-2gmq-w3xh

Code injection in HackerOne RubyGems

Priority MEDIUM 55

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.11102 Published 2017-08-31 Partial fix · 2.6.13 CWE-150
Priority MEDIUM 48

The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted…

CVSS 2.0HIGH 7.5 Network No auth Interaction — EPSS 0.13911 Published 2013-02-13 Partial fix · 1.5.5, 1.6.8 +1 CWE-20
Priority MEDIUM 47

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verificat…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02934 Published 2018-03-13 Partial fix · 2.7.6, 9.1.16.0 CWE-347
Priority MEDIUM 44

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.08491 Published 2017-08-31 Partial fix · 2.6.13 CWE-20
Priority MEDIUM 43

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

CVSS 3.0HIGH 8.1 Network No auth No interaction EPSS 0.0475 Published 2017-08-31 Partial fix · 2.6.13 CWE-350
Priority MEDIUM 41

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversa…

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.04905 Published 2018-03-13 Partial fix · 2.7.6, 9.1.16.0 CWE-59
Priority MEDIUM 40

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caus…

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.04736 Published 2018-03-13 Partial fix · 2.7.6, 9.1.16.0 CWE-835
Priority LOW 39

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of…

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.02881 Published 2018-03-13 Partial fix · 2.7.6, 9.1.16.0 CWE-502
Load more
Open these records in search →