Read the docs
TI-2021-19615 Aliases CVE-2021-43809GHSA-fj7f-vq84-fh43

Local Code Execution through Argument Injection via dash leading git url parameter in Gemfile

Priority LOW 37CWE-88Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-88.

Summary

`Bundler` is a package for managing application dependencies in Ruby. In `bundler` versions before 2.2.33, when working with untrusted and apparently harmless `Gemfile`'s, it is not expected that they lead to execution of external code, unless that's explicit in the ruby code inside the `Gemfile` itself. However, if the `Gemfile` includes `gem` entries that use the `git` option with invalid, but seemingly harmless, values with a leading dash, this can be false. To handle dependencies that come from a Git repository instead of a registry, Bundler uses various commands, such as `git clone`. These commands are being constructed using user input (e.g. the repository URL). When building the commands, Bundler versions before 2.2.33 correctly avoid Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. Since this value comes from the `Gemfile` file, it can contain any character, including a leading dash. To exploit this vulnerability, an attacker has to craft a directory containing a `Gemfile` file that declares a dependency that is located in a Git repository. This dependency has to have a Git URL in the form of `-u./payload`. This URL will be used to construct a Git clone command but will be interpreted as the upload-pack argument. Then this directory needs to be shared with the victim, who then needs to run a command that evaluates the Gemfile, such as `bundle lock`, inside. This vulnerability can lead to Arbitrary Code Execution, which could potentially lead to the takeover of the system. However, the exploitability is very low, because it requires a lot of user interaction. Bundler 2.2.33 has patched this problem by inserting `--` as an argument before any positional arguments to those Git commands that were affected by this issue. Regardless of whether users can upgrade or not, they should review any untrustred `Gemfile`'s before running any `bundler` commands that may read them, since they can contain arbitrary ruby code.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02909 87th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Partial rubygems (rubygems): 2.2.33bundler (RubyGems): 2.2.33Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
rubygemsrubygemsbefore 2.2.332.2.33Patch availableCNA
—bundler (RubyGems)before 2.2.332.2.33Patch availableGHSA-fj7f-vq84-fh43
  • rubygems Vendorrubygems Affected before 2.2.33 Fixed in 2.2.33 Patch available CNA
  • bundler (RubyGems) Vendor— Affected before 2.2.33 Fixed in 2.2.33 Patch available GHSA-fj7f-vq84-fh43

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:bundler:bundler:*:*:*:*:*:ruby:*:*before 2.2.33VulnerableBundler
  • cpe:2.3:a:bundler:bundler:*:*:*:*:*:ruby:*:* Versions before 2.2.33 Vulnerable ·Bundler

Remediation

  • Fix · CNA rubygems (rubygems) Fixed in 2.2.33
  • Fix · GHSA-fj7f-vq84-fh43 bundler (RubyGems) Fixed in 2.2.33 Advisory →

Red Hat 1 advisory

  • RHSA-2025:7539 Released 2025-05-14 · Red Hat rating Moderate
    ruby:2.5 security update
    • Red Hat Enterprise Linux AppStream (v. 8) ruby-2.5.9-114.module+el8.10.0+23088+750dc6ca.aarch64::ruby:2.5, ruby-2.5.9-114.module+el8.10.0+23088+750dc6ca.i686::ruby:2.5, ruby-2.5.9-114.module+el8.10.0+23088+750dc6ca.ppc64le::ruby:2.5 +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 8AffectedNo fix yet
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2025:7539
Not affected: 1 product
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-43809
  2. 2026-10-03 Alias added: GHSA-fj7f-vq84-fh43
  3. 2026-11-02 CISA SSVC decision points changed

References

  • TI-2022-11761 Unauthorized takeover for new versions of some platform-specific gems CVSS 3.1HIGH 7.7
  • TI-2017-00851 Deserialization of untrusted data in HackerOne RubyGems CVSS 3.0CRITICAL 9.8
  • TI-2017-00849 Path traversal in HackerOne RubyGems CVSS 3.0HIGH 7.5
  • TI-2017-00847 Code injection in HackerOne RubyGems CVSS 3.0CRITICAL 9.8
  • TI-2024-14379 rubygems.org MFA Bypass through password reset function could allow account takeover CVSS 3.1CRITICAL 9.8
  • TI-2013-00203 The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows… CVSS 2.0HIGH 7.5
See all 36 →

Sources