The Simple Banner plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `pro_version_activation_code` parameter in versions up to, and including, 2.11.0 due to insufficient input sanitization and outp…
The Simple Banner WordPress plugin before 3.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilte…
CVSS 3.1LOW 3.5·Network·High privileges·User interaction·EPSS 0.00267·Published 2025-03-25·Fixed in 3.0.4CWE-79
The Simple Banner WordPress plugin before 2.12.0 does not properly sanitize its "Simple Banner Text" Settings allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability…
CVSS 3.1MEDIUM 4.8·Network·High privileges·User interaction·EPSS 0.0055·Published 2022-08-22·Fixed in 2.12.0CWE-79
The Simple Banner WordPress plugin before 2.10.4 does not sanitise and escape one of its settings, allowing high privilege users such as admin to use Cross-Site Scripting payload even when the unfiltered_html capability…
CVSS 3.1MEDIUM 4.8·Network·High privileges·User interaction·EPSS 0.00676·Published 2021-08-23·Fixed in 2.10.4CWE-79