Simple Banner < 2.10.4 - Authenticated Stored XSS
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Simple Banner WordPress plugin before 2.10.4 does not sanitise and escape one of its settings, allowing high privilege users such as admin to use Cross-Site Scripting payload even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00676 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Simple Banner (Unknown): 2.10.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Banner | 2.10.4 to before 2.10.4 | 2.10.4 | Patch available | CNA |
- Simple Banner VendorUnknown Affected 2.10.4 to before 2.10.4 Fixed in 2.10.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simple_banner_project:simple_banner:*:*:*:*:*:wordpress:*:* | before 2.10.4 | Vulnerable | Simple Banner Project |
- cpe:2.3:a:simple_banner_project:simple_banner:*:*:*:*:*:wordpress:*:* Versions before 2.10.4 Vulnerable ·Simple Banner Project
Remediation
- Fix · CNA Simple Banner (Unknown) Fixed in 2.10.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24574
- 2026-10-03 Alias added: GHSA-jx5c-5jv3-g74m
References
More Simple Banner Project Simple Banner vulnerabilities
- TI-2022-02324 Simple Banner <= 2.11.0 - Authenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-11833 Simple Banner < 3.0.4 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2022-00369 Simple Banner < 2.12.0 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-24574 · CVE Program
- CVE-2021-24574 · NVD
- FIRST EPSS
- GHSA-jx5c-5jv3-g74m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences