Read the docs

Strapi

Records46All Threatist records
Exploited (KEV)1In CISA KEV
CVSS critical9CVSS 9.0–10.0
CVSS high17CVSS 7.0–8.9

Exploited now

Strapi records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

46 records

Priority CRITICAL 91KEV

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.04114 Published 2023-04-19 Fixed in 4.8.0 CWE-312
Priority CRITICAL 87

strapi before 3.0.0-beta.17.5 mishandles password resets within packages/strapi-admin/controllers/Auth.js and packages/strapi-plugin-users-permissions/controllers/Auth.js.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.97639 Published 2019-11-07 Fixed in 3.0.0-beta.17.5 CWE-640
TI-2023-19887 CVE-2023-38507 · GHSA-24q2-59hm-rh9r

Strapi Improper Rate Limiting vulnerability

Priority HIGH 81

Strapi is the an open-source headless content management system.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00963 Published 2023-09-15 Fixed in 4.12.1 CWE-770
Priority MEDIUM 64

The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.54081 Published 2019-12-05 Fixed in 3.0.0-beta.17.8 CWE-78
Priority MEDIUM 57

Strapi 5.47.0 through 5.57.0 contains an improper authorization vulnerability that allows admin API tokens to retain all-field Content Manager access after the owner's role is field-restricted.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00199 Published 2026-10-10 No fix listed CWE-863
Priority MEDIUM 47

The strapi/review-workflows package is vulnerable to a broken access control vulnerability allowing updates to be made without verifying whether the caller possesses update rights for the underlying document.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00287 Published 2026-10-27 No fix listed CWE-862
Priority MEDIUM 42

Strapi versions 4.x through 4.26.2 and 5.x before 5.48.1 contain a stored cross-site scripting vulnerability in the content manager WYSIWYG preview component that fails to strip script tags from rich text.

CVSS 4.0CRITICAL 9.3 Network Low privileges User interaction EPSS 0.0043 Published 2026-09-13 Fixed in 5.48.1 CWE-79
Load more
Open these records in search →