Read the docs
TI-2023-08803 Aliases CVE-2023-22621GHSA-2h87-4q2w-v4hf

Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can…

Priority HIGH 80CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can be exploited to execute arbitrary code on the server. A remote attacker with access to the Strapi admin panel can inject a crafted payload that executes code on the server into an email template that bypasses the validation checks that should prevent code execution.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.706 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @strapi/plugin-users-permissions (npm): 4.5.6@strapi/plugin-email (npm): 4.5.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—@strapi/plugin-users-permissions (npm)before 4.5.64.5.6Patch availableGHSA-2h87-4q2w-v4hf
—@strapi/plugin-email (npm)before 4.5.64.5.6Patch availableGHSA-2h87-4q2w-v4hf
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • @strapi/plugin-users-permissions (npm) Vendor— Affected before 4.5.6 Fixed in 4.5.6 Patch available GHSA-2h87-4q2w-v4hf
  • @strapi/plugin-email (npm) Vendor— Affected before 4.5.6 Fixed in 4.5.6 Patch available GHSA-2h87-4q2w-v4hf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:strapi:strapi:*:*:*:*:*:*:*:*3.0.0 to before 4.5.6VulnerableStrapi
  • cpe:2.3:a:strapi:strapi:*:*:*:*:*:*:*:* Versions 3.0.0 to before 4.5.6 Vulnerable ·Strapi

Remediation

  • Fix · GHSA-2h87-4q2w-v4hf @strapi/plugin-users-permissions (npm) Fixed in 4.5.6 Advisory →
  • Fix · GHSA-2h87-4q2w-v4hf @strapi/plugin-email (npm) Fixed in 4.5.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-22621
  2. 2026-10-03 Alias added: GHSA-2h87-4q2w-v4hf

References

  • TI-2023-09037 Query filter flaw in Strapi exposes sensitive user details KEVCVSS 3.1HIGH 7.2
  • TI-2019-13554 strapi before 3.0.0-beta.17.5 mishandles password resets within… CVSS 3.1CRITICAL 9.8
  • TI-2023-19887 Strapi Improper Rate Limiting vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-25161 Strapi v4.24.4 was discovered to contain a Server-Side Request Forgery (SSRF) via the… CVSS 3.1HIGH 8.6
  • TI-2023-17071 Leaking sensitive user information still possible by filtering on private with prefix fields CVSS 3.1HIGH 8.6
  • TI-2024-37136 Strapi Allows Unauthorized Access to Private Fields via parms.lookup CVSS 3.1HIGH 8.2
See all 38 →

Sources