Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpo…
CVSS 4.0CRITICAL 9.3·Network·No auth·No interaction·EPSS 0.00511·Published 2026-07-07·Fixed in 1.2.0, 1.5.0CWE-306