topoteretes cognee JWT Signing Key get_api_auth_backend.py get_user_id_by_email hard-coded credentials
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-259.
Summary
A security flaw has been discovered in topoteretes cognee up to 1.5.4. The affected element is the function get_user_id_by_email of the file cognee/modules/users/authentication/get_api_auth_backend.py of the component JWT Signing Key Handler. The manipulation of the argument FASTAPI_USERS_JWT_SECRET results in hard-coded credentials. The attack may be launched remotely. Upgrading to version 1.6.0 is sufficient to fix this issue. The patch is identified as fa65fc0cd86cdba48d19aa76e36be862be982f5d. Upgrading the affected component is advised.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| topoteretes | cognee | 1.5.0; 1.5.1; 1.5.2; 1.5.3; 1.5.4 | 1.6.0 | Patch available | CNA |
- cognee Vendortopoteretes Affected 1.5.0; 1.5.1; 1.5.2; 1.5.3; 1.5.4 Fixed in 1.6.0 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:topoteretes:cognee:*:*:*:*:*:*:*:* | — | — | topoteretes |
- cpe:2.3:a:topoteretes:cognee:*:*:*:*:*:*:*:* Versions — — ·topoteretes
Remediation
- Fix · CNA cognee (topoteretes) Fixed in 1.6.0
Timeline
- 2026-10-04 Threatist record created from CVE-2026-105141
- 2026-10-04 Alias added: GHSA-xrgh-2vxr-rhm4
- 2026-10-05 CISA SSVC decision points changed
References
Patch 3
More topoteretes vulnerabilities
- TI-2026-42077 Cognee < 1.2.0 Unauthorized LLM Configuration Overwrite via /api/v1/settings CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-105141 · CVE Program
- CVE-2026-105141 · NVD
- FIRST EPSS
- GHSA-xrgh-2vxr-rhm4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences