Priority HIGH 74
The from method in library/core/class.email.php in Vanilla Forums before 2.3.1 allows remote attackers to spoof the email domain in sent messages and potentially obtain sensitive information via a crafted HTTP Host heade…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.83614 · Published 2017-05-23 · No fix listed CWE-200
Priority MEDIUM 50
Vanilla 2.6.x before 2.6.4 allows remote code execution.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05152 · Published 2018-11-03 · No fix listed CWE-94
Priority MEDIUM 46
An Access Control vulnerability exists in the Facebook, Twitter, and Embedded plugins in Vanilla Forums before 2.0.17.9.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01958 · Published 2020-01-22 · Fixed in 2.0.17.9
Priority MEDIUM 41
Unspecified vulnerability in the update check in Vanilla Forums before 2.0.18.8 has unspecified impact and remote attack vectors, related to "object injection."
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.05667 · Published 2013-05-10 · No fix listed
Priority LOW 39
Multiple SQL injection vulnerabilities in Vanilla Forums before 2.0.18.8 allow remote attackers to execute arbitrary SQL commands via the parameter name in the Form/Email array to (1) entry/signin or (2) entry/passwordre…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.03511 · Published 2013-05-10 · No fix listed CWE-89
Priority LOW 36
Vanilla before 2.5.5 and 2.6.x before 2.6.2 allows Remote Code Execution because authenticated administrators have a reachable call to unserialize in the Gdn_Format class.
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.02017 · Published 2018-11-23 · No fix listed CWE-502
Priority LOW 36
An issue exists in Vanilla Forums before 2.0.17.9 due to the way cookies are handled.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0173 · Published 2020-01-22 · Fixed in 2.0.17.9 CWE-200
Priority LOW 31
Vanilla before 2.6.1 allows SQL injection via an invitationID array to /profile/deleteInvitation, related to applications/dashboard/models/class.invitationmodel.php and applications/dashboard/controllers/class.profilecon…
CVSS 3.0MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.0094 · Published 2018-09-03 · No fix listed CWE-89
Priority LOW 31
The cookie implementation in Vanilla Forums before 2.0.17.6 makes it easier for remote attackers to spoof signed requests, and consequently obtain access to arbitrary user accounts, via HMAC timing attacks.
CVSS 2.0MEDIUM 6.4· Network · No auth · Interaction — · EPSS 0.01047 · Published 2011-02-08 · No fix listed
Priority LOW 29
Vanilla Forums 2.0.17.1 through 2.0.17.5 has XSS in /vanilla/index.php via the p parameter.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00804 · Published 2020-02-05 · No fix listed CWE-79
Priority LOW 28
index.php?p=/dashboard/settings/branding in Vanilla 2.6.3 allows stored XSS.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.0189 · Published 2020-02-10 · No fix listed CWE-79
Priority LOW 28
Vanilla before 2.6.1 allows XSS via the email field of a profile.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00675 · Published 2018-09-28 · No fix listed CWE-79
Priority LOW 28
Open redirect vulnerability in Vanilla Forums before 2.0.17.6 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the Target parameter to an unspecified component, a…
CVSS 2.0MEDIUM 5.8· Network · No auth · Interaction — · EPSS 0.00959 · Published 2011-02-08 · No fix listed CWE-20
Priority LOW 25
Vanilla 2.0.16 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by plugins/Minify/min/utils.php and cer…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.01229 · Published 2011-09-24 · No fix listed CWE-200
Priority LOW 24
Multiple cross-site scripting (XSS) vulnerabilities in Vanilla Forums before 2.0.18.13 and 2.1.x before 2.1.1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01773 · Published 2015-02-25 · No fix listed CWE-79
Priority LOW 23
Cross-site scripting (XSS) vulnerability in index.php in Vanilla Forums before 2.0.17 allows remote attackers to inject arbitrary web script or HTML via the Target parameter in a /entry/signin action.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01272 · Published 2011-02-08 · No fix listed CWE-79
Priority LOW 22
Cross-site scripting (XSS) vulnerability in Vanilla Forums before 2.0.17.6 allows remote attackers to inject arbitrary web script or HTML via the p parameter to an unspecified component, a different vulnerability than CV…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.00855 · Published 2011-02-08 · No fix listed CWE-79
Priority LOW 19
The edit-profile page in Vanilla Forums before 2.1a32 allows remote authenticated users to modify arbitrary profile settings by replacing the UserID value during a man-in-the-middle attack, related to a "parameter manipu…
CVSS 2.0LOW 3.5· Network · Low privileges · Interaction — · EPSS 0.01067 · Published 2012-11-15 · No fix listed CWE-264
Priority LOW 18
In Vanilla before 2.6.4, a flaw exists within the getSingleIndex function of the AddonManager class.
CVSS 3.0LOW 2.7· Network · High privileges · No interaction · EPSS 0.02381 · Published 2019-03-20 · No fix listed CWE-22