The WP-Ban WordPress plugin before 1.69.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_ht…
CVSS 3.1MEDIUM 4.8·Network·High privileges·User interaction·EPSS 0.00894·Published 2023-01-02·Fixed in 1.69.1
WP-Ban plugin before 1.6.4 for WordPress, when running in certain configurations, allows remote attackers to bypass the IP blacklist via a crafted X-Forwarded-For header.