WP-Ban < 1.69.1 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP-Ban WordPress plugin before 1.69.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00894 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP-Ban (Unknown): 1.69.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP-Ban | before 1.69.1 | 1.69.1 | Patch available | CNA |
- WP-Ban VendorUnknown Affected before 1.69.1 Fixed in 1.69.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-ban_project:wp-ban:*:*:*:*:*:wordpress:*:* | before 1.69.1 | Vulnerable | Wp-ban Project |
- cpe:2.3:a:wp-ban_project:wp-ban:*:*:*:*:*:wordpress:*:* Versions before 1.69.1 Vulnerable ·Wp-ban Project
Remediation
- Fix · CNA WP-Ban (Unknown) Fixed in 1.69.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4260
- 2026-10-03 Alias added: GHSA-7wx2-wjvp-v5h2
References
More Wp-ban Project Wp-ban vulnerabilities
- TI-2022-04232 WP-Ban ban-options.php cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2021-03110 WP-Ban ban-options.php toggle_checkbox cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2014-05128 WP-Ban plugin before 1.6.4 for WordPress, when running in certain configurations, allows… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2022-4260 · CVE Program
- CVE-2022-4260 · NVD
- FIRST EPSS
- GHSA-7wx2-wjvp-v5h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences