Read the docs

Wp-polls Project

Records5All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high0CVSS 7.0–8.9

Exploited now

Wp-polls Project records in CISA KEV

No Wp-polls Project vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

5 records

TI-2022-01452 CVE-2022-1581 · GHSA-27qm-jwxp-8whw

WP-Polls < 2.76.0 - IP Validation Bypass

Priority MEDIUM 57

The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00698 Published 2022-11-21 Fixed in 2.76.0
Priority LOW 25

The WP-Polls plugin for WordPress is vulnerable to SQL Injection via COOKIE in all versions up to, and including, 2.77.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on t…

CVSS 3.1MEDIUM 5.4 Network No auth No interaction EPSS 0.00491 Published 2025-01-22 No fix listed CWE-89
Open these records in search →