WP-Polls < 2.76.0 - IP Validation Bypass
Priority MEDIUM 57Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00698 53rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed WP-Polls (Unknown): 2.76.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP-Polls | before 2.76.0 | 2.76.0 | Patch available | CNA |
- WP-Polls VendorUnknown Affected before 2.76.0 Fixed in 2.76.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-polls_project:wp-polls:*:*:*:*:*:wordpress:*:* | before 2.76.0 | Vulnerable | Wp-polls Project |
- cpe:2.3:a:wp-polls_project:wp-polls:*:*:*:*:*:wordpress:*:* Versions before 2.76.0 Vulnerable ·Wp-polls Project
Remediation
- Fix · CNA WP-Polls (Unknown) Fixed in 2.76.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1581
- 2026-10-03 Alias added: GHSA-27qm-jwxp-8whw
References
More Wp-polls Project Wp-polls vulnerabilities
- TI-2015-07729 The wp-polls plugin before 2.72 for WordPress has SQL injection. CVSS 3.0CRITICAL 9.8
- TI-2016-08974 The wp-polls plugin before 2.73.1 for WordPress has XSS via the Poll bar option. CVSS 3.0MEDIUM 6.1
- TI-2024-12467 WP-Polls <= 2.77.2 - Unauthenticated SQL Injection to Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2022-19020 WordPress WP-Polls plugin <= 2.76.0 - Auth. Race Condition vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-1581 · CVE Program
- CVE-2022-1581 · NVD
- FIRST EPSS
- GHSA-27qm-jwxp-8whw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences