WordPress Plugin WPGraphQL 1.3.5 contains a denial of service vulnerability that allows unauthenticated attackers to exhaust server resources by sending batched GraphQL queries with duplicated fields.
WPGraphQL before 2.24.1 contains a missing rate limiting vulnerability that allows unauthenticated attackers to flood password reset emails by aliasing the sendPasswordResetEmail mutation.
CVSS 4.0MEDIUM 6.9·Network·No auth·No interaction·EPSS 0.0059·Published 2026-10-30·Fixed in 2.24.1CWE-770
WPGraphQL Smart Cache before 2.3.3 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to persist unlimited query documents via the Automatic Persisted Query handler.
CVSS 4.0MEDIUM 6.9·Network·No auth·No interaction·EPSS 0.00454·Published 2026-10-30·Fixed in 2.3.3CWE-770
WPGraphQL before 2.24.1 contains a missing authorization vulnerability in the createComment mutation that allows unauthenticated attackers to comment on non-public posts by bypassing post status checks.
CVSS 4.0MEDIUM 6.9·Network·No auth·No interaction·EPSS 0.00361·Published 2026-10-30·Fixed in 2.24.1CWE-862
WPGraphQL before 2.24.2 contains an information disclosure vulnerability that allows unauthenticated attackers to determine object existence through distinct error responses.
CVSS 4.0MEDIUM 6.9·Network·No auth·No interaction·EPSS 0.00363·Published 2026-10-30·Fixed in 2.24.2CWE-204