Read the docs

YayCommerce

Records32All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high19CVSS 7.0–8.9

Exploited now

YayCommerce records in CISA KEV

No YayCommerce vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

32 records

Priority MEDIUM 51

The YayExtra – WooCommerce Extra Product Options plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the handle_upload_file function in all versions up to, and including, 1…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01001 Published 2024-08-03 No fix listed CWE-434
Priority MEDIUM 41

The YaySMTP – WP Mail SMTP with Email Logs, Tracking & Reports plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.7.7 via the putFile function.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00559 Published 2026-10-16 No fix listed CWE-434
Priority LOW 39

Missing Authorization vulnerability in YayCommerce YayCurrency yaycurrency allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YayCurrency: from n/a through <= 3.3.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00375 Published 2026-02-20 No fix listed CWE-862
Priority LOW 39

Missing Authorization vulnerability in YayCommerce YayPricing yaypricing allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects YayPricing: from n/a through <= 3.5.3.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00341 Published 2025-12-18 No fix listed CWE-862
Priority LOW 38

The SMTP for Amazon SES – YaySMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Email Logs in all versions up to, and including, 1.8 due to insufficient input sanitization and output escaping.

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00505 Published 2025-04-11 No fix listed CWE-79
Priority LOW 38

The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient inpu…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00382 Published 2025-02-19 No fix listed CWE-79
Priority LOW 38

The YaySMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 2.4.5 due to insufficient input sanitization and output escaping.

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00462 Published 2023-07-12 No fix listed CWE-79
Priority LOW 35

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce SMTP for Amazon SES smtp-amazon-ses allows SQL Injection.This issue affects SMTP for Amazon SES: from n/a…

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00338 Published 2025-07-16 No fix listed CWE-89
Priority LOW 35

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce SMTP for SendGrid – YaySMTP smtp-sendgrid allows SQL Injection.This issue affects SMTP for SendGrid – YayS…

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00417 Published 2025-07-16 No fix listed CWE-89
Priority LOW 35

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce YayExtra yayextra allows SQL Injection.This issue affects YayExtra: from n/a through <= 1.5.5.

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00417 Published 2025-07-16 No fix listed CWE-89
Priority LOW 34

The YayMail – WooCommerce Email Customizer plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the `yaymail_import_state` AJA…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.00463 Published 2026-02-18 No fix listed CWE-862
Priority LOW 34

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce YaySMTP yaysmtp allows Blind SQL Injection.This issue affects YaySMTP: from n/a through <= 2.6.4.

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00442 Published 2025-05-07 No fix listed CWE-89
Priority LOW 33

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce YayMail yaymail allows Blind SQL Injection.This issue affects YayMail: from n/a through <= 4.3.3.

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.0029 Published 2026-04-08 No fix listed CWE-89
Priority LOW 33

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce YaySMTP yaysmtp allows SQL Injection.This issue affects YaySMTP: from n/a through <= 2.6.6.

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00417 Published 2025-06-27 No fix listed CWE-89
Priority LOW 33

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce YaySMTP smtp-sendinblue allows SQL Injection.This issue affects YaySMTP: from n/a through <= 1.3.

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00417 Published 2025-07-16 No fix listed CWE-89
Priority LOW 33

Missing Authorization vulnerability in YayCommerce YayExtra yayextra allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YayExtra: from n/a through <= 1.5.2.

CVSS 3.1HIGH 7.6 Network Low privileges No interaction EPSS 0.00354 Published 2025-04-01 No fix listed CWE-862
Priority LOW 31

The YaySMTP WordPress plugin before 2.2.1 does not have capability check before displaying the Mailer Credentials in JS code for the settings, allowing any authenticated users, such as subscriber to retrieve them

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00938 Published 2022-08-01 Fixed in 2.2.1 CWE-862
Priority LOW 30

The YayMail – WooCommerce Email Customizer plugin for WordPress is vulnerable to unauthorized license key deletion due to a missing authorization check on the `/yaymail-license/v1/license/delete` REST endpoint in version…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00346 Published 2026-02-18 No fix listed CWE-862
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yaycommerce Brand brand allows Stored XSS.This issue affects Brand: from n/a through <= 1.1.6.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00226 Published 2024-12-16 No fix listed CWE-79
Priority LOW 25

The YaySMTP WordPress plugin before 2.2.1 does not have proper authorisation when saving its settings, allowing users with a role as low as subscriber to change them, and use that to conduct Stored Cross-Site Scripting a…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00624 Published 2022-08-08 Fixed in 2.2.1 CWE-79
Load more
Open these records in search →