Read the docs
TI-2025-00779 Aliases CVE-2025-0916GHSA-fv43-fjwv-823r

YaySMTP 2.4.9 - 2.6.2 - Unauthenticated Stored Cross-Site Scripting

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: The vulnerability has been initially patched in version 2.4.8 and was reintroduced in version 2.4.9 with the removal of the wp_kses_post() built-in WordPress sanitization function.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00382 32nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
YayCommerceYaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service2.4.9 – 2.6.2—No fix listedCNA
  • YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service VendorYayCommerce Affected 2.4.9 – 2.6.2 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:yaycommerce:yaysmtp:*:*:*:*:*:wordpress:*:*2.4.9 to before 2.6.3VulnerableYayCommerce
  • cpe:2.3:a:yaycommerce:yaysmtp:*:*:*:*:*:wordpress:*:* Versions 2.4.9 to before 2.6.3 Vulnerable ·YayCommerce

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-0916
  2. 2026-10-03 Alias added: GHSA-fv43-fjwv-823r

References

  • TI-2025-00808 SMTP for Sendinblue – YaySMTP <= 1.2 - Unauthenticated Stored Cross-Site Scripting via Email Logs CVSS 3.1HIGH 7.2
  • TI-2025-00781 SMTP for SendGrid – YaySMTP <= 1.4 - Unauthenticated Stored Cross-Site Scripting via Email Logs CVSS 3.1HIGH 7.2
  • TI-2023-02899 YaySMTP <= 2.4.5 - Unauthenticated Stored Cross-Site Scripting via Email CVSS 3.1HIGH 7.2
  • TI-2022-02186 YaySMTP < 2.2.1 - Subscriber+ SMTP Credentials Leak CVSS 3.1MEDIUM 6.5
  • TI-2022-02187 YaySMTP < 2.2.1 - Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
  • TI-2022-02188 YaySMTP < 2.2.2 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
See all 7 →

Sources