Rapyd Admin from 9.0.0 before 9.20.0 contains a hard-coded credentials vulnerability that allows remote unauthenticated attackers to gain super-admin access through an AuthSeeder-created admin@laravel account with passwo…
CVSS 4.0CRITICAL 9.3·Network·No auth·No interaction·EPSS 0.00668·Published 2026-10-12·Fixed in 9.20.0CWE-798
Rapyd Admin from 9.0.0 before 9.20.0 contains an authorization bypass vulnerability that allows authenticated company members with the default customer role to modify or delete arbitrary user accounts through the UsersMo…
CVSS 4.0HIGH 8.7·Network·Low privileges·No interaction·EPSS 0.0046·Published 2026-10-13·Fixed in 9.20.0CWE-639
Rapyd Admin from 9.0.0 before 9.20.0 contains an improper privilege management vulnerability in the UsersEdit Livewire component that allows users with the edit users permission to assign themselves the admin role.
CVSS 4.0HIGH 8.6·Network·High privileges·No interaction·EPSS 0.00329·Published 2026-10-12·Fixed in 9.20.0CWE-269
Rapyd Admin from 9.4.0 before 9.20.0 contains a stored cross-site scripting vulnerability that allows unauthenticated attackers to inject scripts through self-registered display names.
CVSS 4.0MEDIUM 5.3·Network·No auth·User interaction·EPSS 0.00211·Published 2026-10-12·Fixed in 9.20.0CWE-79
Rapyd Admin before 9.20.0 contains a stored cross-site scripting vulnerability in the x-rpd::rich-text Blade component that outputs bound model values as raw HTML without sanitisation.
CVSS 4.0LOW 2.1·Network·Low privileges·User interaction·EPSS 0.00235·Published 2026-10-13·Fixed in 9.20.0CWE-79