Zope before 2.2.1 does not properly restrict access to the getRoles method, which allows…
Priority LOW 32CWE-284Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Zope before 2.2.1 does not properly restrict access to the getRoles method, which allows users who can edit DTML to add or modify roles by modifying the roles list that is included in a request.
Why it matters now
EPSS 0.00471 40th percentileScored 2026-11-07
Fix Fixed zope (PyPI): 2.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zope (PyPI) | before 2.2.1 | 2.2.1 | Patch available | GHSA-9cmq-pj6p-hgwf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zope (PyPI) Vendor— Affected before 2.2.1 Fixed in 2.2.1 Patch available GHSA-9cmq-pj6p-hgwf
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:1.10.3:*:*:*:*:*:*:* | 1.10.3 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.1.7:*:*:*:*:*:*:* | 2.1.7 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.2_beta1:*:*:*:*:*:*:* | 2.2_beta1 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:1.10.3:*:*:*:*:*:*:* Versions 1.10.3 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.1.7:*:*:*:*:*:*:* Versions 2.1.7 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.2_beta1:*:*:*:*:*:*:* Versions 2.2_beta1 Vulnerable ·zopefoundation
Remediation
- Fix · GHSA-9cmq-pj6p-hgwf zope (PyPI) Fixed in 2.2.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2000-0725
- 2026-10-03 Alias added: GHSA-9cmq-pj6p-hgwf
References
Advisory 3
Other 4
- http://www.zope.org/Products/Zope/Hotfix_08_09_2000/security_alert
- https://web.archive.org/web/20010219192346/http://archives.neohapsis.com/archives/bugtraq/2000-08/0198.html
- https://web.archive.org/web/20010219192441/http://archives.neohapsis.com/archives/bugtraq/2000-08/0259.html
- https://web.archive.org/web/20010228172804/http://www.securityfocus.com/bid/1577
More zopefoundation Zope vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2000-00062 The DTML implementation in the Z Object Publishing Environment (Zope) allows remote… CVSS 2.0HIGH 10.0
- TI-2021-12302 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2021-12342 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2005-03148 docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2000-00483 The DocumentTemplate package in Zope 2.2 and earlier allows a remote attacker to modify… CVSS 2.0HIGH 7.5
Sources
- CVE-2000-0725 · CVE Program
- CVE-2000-0725 · NVD
- FIRST EPSS
- GHSA-9cmq-pj6p-hgwf · GitHub Advisory Database · CC BY 4.0
- CVE-2000-0725 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences