Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy…
Priority LOW 36CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-284.
Summary
Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.
Why it matters now
EPSS 0.01584 75th percentileScored 2026-11-07
Fix Fixed zope (PyPI): 2.4.4, 2.5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zope (PyPI) | 2.2.0 to before 2.4.4 | 2.4.4 | Patch available | GHSA-c3rp-4cjh-cp38 |
| — | zope (PyPI) | 2.5.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-c3rp-4cjh-cp38 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zope (PyPI) Vendor— Affected 2.2.0 to before 2.4.4 Fixed in 2.4.4 Patch available GHSA-c3rp-4cjh-cp38
- zope (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-c3rp-4cjh-cp38
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.2.3:*:*:*:*:*:*:* | 2.2.3 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.2.4:*:*:*:*:*:*:* | 2.2.4 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.2.5:*:*:*:*:*:*:* | 2.2.5 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.2.3:*:*:*:*:*:*:* Versions 2.2.3 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.2.4:*:*:*:*:*:*:* Versions 2.2.4 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.2.5:*:*:*:*:*:*:* Versions 2.2.5 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·zopefoundation
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.4.2:*:*:*:*:*:*:* | 2.4.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.4.3:*:*:*:*:*:*:* | 2.4.3 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.4.4b1:*:*:*:*:*:*:* | 2.4.4b1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.5.1b1:*:*:*:*:*:*:* | 2.5.1b1 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.4.4b1:*:*:*:*:*:*:* Versions 2.4.4b1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.5.1b1:*:*:*:*:*:*:* Versions 2.5.1b1 Vulnerable ·zopefoundation
Remediation
- Fix · GHSA-c3rp-4cjh-cp38 zope (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-c3rp-4cjh-cp38 zope (PyPI) Fixed in 2.5.1 Advisory →
Vendor assessments
Red Hat
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Powertools 7.0 | Fixed | RHSA-2002:060 |
| Red Hat Powertools 7.1 | Fixed | RHSA-2002:060 |
Timeline
- 2026-10-02 Threatist record created from CVE-2002-0170
- 2026-10-03 Alias added: GHSA-c3rp-4cjh-cp38
References
Other 8
- 20020301 [[email protected]: [Zope-Annce] Zope Hotfix 2002-03-01 (Ownership Roles Enforcement)]
- zope-proxy-role-privileges(8334)
- 5350
- https://github.com/zopefoundation/Zope
- https://launchpad.net/zope2/+milestone/2.4.4
- https://launchpad.net/zope2/+milestone/2.5.1
- https://web.archive.org/web/20021120034302/http://online.securityfocus.com/bid/4229
- https://web.archive.org/web/20070914020022/http://xforce.iss.net/xforce/xfdb/8334
More zopefoundation Zope vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2000-00062 The DTML implementation in the Z Object Publishing Environment (Zope) allows remote… CVSS 2.0HIGH 10.0
- TI-2021-12302 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2021-12342 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2005-03148 docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2000-00483 The DocumentTemplate package in Zope 2.2 and earlier allows a remote attacker to modify… CVSS 2.0HIGH 7.5
Sources
- CVE-2002-0170 · CVE Program
- CVE-2002-0170 · NVD
- FIRST EPSS
- GHSA-c3rp-4cjh-cp38 · GitHub Advisory Database · CC BY 4.0
- CVE-2002-0170 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences