The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted…
Priority LOW 26CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.
Why it matters now
EPSS 0.01479 74th percentileScored 2026-11-07
Fix Fixed zope (PyPI): 2.4.4b2, 2.5.1b2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zope (PyPI) | 2.0.0 to before 2.4.4b2 | 2.4.4b2 | Patch available | GHSA-vwrc-g9q6-f675 |
| — | zope (PyPI) | 2.5.0 to before 2.5.1b2 | 2.5.1b2 | Patch available | GHSA-vwrc-g9q6-f675 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zope (PyPI) Vendor— Affected 2.0.0 to before 2.4.4b2 Fixed in 2.4.4b2 Patch available GHSA-vwrc-g9q6-f675
- zope (PyPI) Vendor— Affected 2.5.0 to before 2.5.1b2 Fixed in 2.5.1b2 Patch available GHSA-vwrc-g9q6-f675
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* | up to 2.5.1b1 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* Versions up to 2.5.1b1 Vulnerable ·zopefoundation
Remediation
- Fix · GHSA-vwrc-g9q6-f675 zope (PyPI) Fixed in 2.4.4b2 Advisory →
- Fix · GHSA-vwrc-g9q6-f675 zope (PyPI) Fixed in 2.5.1b2 Advisory →
Vendor assessments
Red Hat
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Powertools 7.0 | Fixed | RHSA-2002:060 |
| Red Hat Powertools 7.1 | Fixed | RHSA-2002:060 |
Timeline
- 2026-10-02 Threatist record created from CVE-2002-0687
- 2026-10-03 Alias added: GHSA-vwrc-g9q6-f675
References
Other 7
- 5166
- zope-inject-headers-dos(9621)
- https://marc.info/?l=zope-announce&m=101890177815066&w=2
- https://marc.info/?l=zope-announce&m=101897461507941&w=2
- https://marc.info/?l=zope-announce&m=101897462107967&w=2
- https://web.archive.org/web/20020822024423/http://www.iss.net/security_center/static/9621.php
- https://web.archive.org/web/20021018100409/http://online.securityfocus.com/bid/5813
More zopefoundation Zope vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2000-00062 The DTML implementation in the Z Object Publishing Environment (Zope) allows remote… CVSS 2.0HIGH 10.0
- TI-2021-12302 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2021-12342 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2005-03148 docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2000-00483 The DocumentTemplate package in Zope 2.2 and earlier allows a remote attacker to modify… CVSS 2.0HIGH 7.5
Sources
- CVE-2002-0687 · CVE Program
- CVE-2002-0687 · NVD
- FIRST EPSS
- GHSA-vwrc-g9q6-f675 · GitHub Advisory Database · CC BY 4.0
- CVE-2002-0687 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences