Read the docs
TI-2003-00034 Aliases CVE-2003-0038GHSA-82rm-28q9-435p

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote…

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Why it matters now

EPSS 0.0476 91st percentileScored 2026-11-07
Fix Fixed mailman (PyPI): 2.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mailman (PyPI)before 2.1.12.1.1Patch availableGHSA-82rm-28q9-435p
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mailman (PyPI) Vendor— Affected before 2.1.1 Fixed in 2.1.1 Patch available GHSA-82rm-28q9-435p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:gnu:mailman:2.1:*:*:*:*:*:*:*2.1VulnerableGNU
  • cpe:2.3:a:gnu:mailman:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·GNU

Remediation

  • Fix · GHSA-82rm-28q9-435p mailman (PyPI) Fixed in 2.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2003-0038
  2. 2026-10-03 Alias added: GHSA-82rm-28q9-435p

References

  • TI-2025-28486 Path traversal in GNU Mailman CVSS 3.1HIGH 7.5
  • TI-2025-28487 OS command injection in GNU Mailman CVSS 3.1HIGH 8.1
  • TI-2025-28488 Incorrect authorization in GNU Mailman CVSS 3.1MEDIUM 5.3
  • TI-2015-02450 Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static… CVSS 2.0HIGH 7.6
  • TI-2002-00830 Cross-site scripting vulnerability in Mailman before 2.0.12 allows remote attackers to… CVSS 2.0HIGH 7.5
  • TI-2002-00374 Cross-site scripting vulnerabilities in Mailman before 2.0.11 allow remote attackers to… CVSS 2.0HIGH 7.5
See all 46 →

Sources