Mailman before 2.1.5 allows remote attackers to obtain user passwords via a crafted email request to the Mailman server.
Priority LOW 28CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Mailman before 2.1.5 allows remote attackers to obtain user passwords via a crafted email request to the Mailman server.
Why it matters now
EPSS 0.03008 87th percentileScored 2026-11-07
Fix Fixed mailman (PyPI): 2.1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mailman (PyPI) | before 2.1.5 | 2.1.5 | Patch available | GHSA-hj4h-vqpq-95wg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mailman (PyPI) Vendor— Affected before 2.1.5 Fixed in 2.1.5 Patch available GHSA-hj4h-vqpq-95wg
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnu:mailman:2.1:*:*:*:*:*:*:* | 2.1 | Vulnerable | GNU |
| cpe:2.3:a:gnu:mailman:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | GNU |
| cpe:2.3:a:gnu:mailman:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | GNU |
| cpe:2.3:a:gnu:mailman:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | GNU |
| cpe:2.3:a:gnu:mailman:2.1.4:*:*:*:*:*:*:* | 2.1.4 | Vulnerable | GNU |
| cpe:2.3:a:gnu:mailman:2.1b1:*:*:*:*:*:*:* | 2.1b1 | Vulnerable | GNU |
- cpe:2.3:a:gnu:mailman:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·GNU
- cpe:2.3:a:gnu:mailman:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·GNU
- cpe:2.3:a:gnu:mailman:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·GNU
- cpe:2.3:a:gnu:mailman:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·GNU
- cpe:2.3:a:gnu:mailman:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·GNU
- cpe:2.3:a:gnu:mailman:2.1b1:*:*:*:*:*:*:* Versions 2.1b1 Vulnerable ·GNU
Remediation
- Fix · GHSA-hj4h-vqpq-95wg mailman (PyPI) Fixed in 2.1.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2004-0412
- 2026-10-03 Alias added: GHSA-hj4h-vqpq-95wg
References
More GNU Mailman vulnerabilities
- TI-2025-28486 Path traversal in GNU Mailman CVSS 3.1HIGH 7.5
- TI-2025-28487 OS command injection in GNU Mailman CVSS 3.1HIGH 8.1
- TI-2025-28488 Incorrect authorization in GNU Mailman CVSS 3.1MEDIUM 5.3
- TI-2015-02450 Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static… CVSS 2.0HIGH 7.6
- TI-2002-00830 Cross-site scripting vulnerability in Mailman before 2.0.12 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2002-00374 Cross-site scripting vulnerabilities in Mailman before 2.0.11 allow remote attackers to… CVSS 2.0HIGH 7.5
Sources
- CVE-2004-0412 · CVE Program
- CVE-2004-0412 · NVD
- FIRST EPSS
- GHSA-hj4h-vqpq-95wg · GitHub Advisory Database · CC BY 4.0
- CVE-2004-0412 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences