Read the docs
TI-2004-01071 Aliases CVE-2004-1177GHSA-rh6c-jh4c-9fg3

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5…

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

Why it matters now

EPSS 0.01797 78th percentileScored 2026-11-07
Fix Fixed mailman (PyPI): 2.1.5Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mailman (PyPI)before 2.1.52.1.5Patch availableGHSA-rh6c-jh4c-9fg3
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mailman (PyPI) Vendor— Affected before 2.1.5 Fixed in 2.1.5 Patch available GHSA-rh6c-jh4c-9fg3

CPE configurations NVD · 25

CPEVersionsRoleVendor
cpe:2.3:a:gnu:mailman:1.0:*:*:*:*:*:*:*1.0VulnerableGNU
cpe:2.3:a:gnu:mailman:1.1:*:*:*:*:*:*:*1.1VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0:*:*:*:*:*:*:*2.0VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0:beta3:*:*:*:*:*:*2.0 beta3VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0:beta4:*:*:*:*:*:*2.0 beta4VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0:beta5:*:*:*:*:*:*2.0 beta5VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.1:*:*:*:*:*:*:*2.0.1VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.2:*:*:*:*:*:*:*2.0.2VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.3:*:*:*:*:*:*:*2.0.3VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.4:*:*:*:*:*:*:*2.0.4VulnerableGNU
  • cpe:2.3:a:gnu:mailman:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0:beta3:*:*:*:*:*:* Versions 2.0 beta3 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0:beta4:*:*:*:*:*:* Versions 2.0 beta4 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0:beta5:*:*:*:*:*:* Versions 2.0 beta5 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·GNU
Show 15 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:gnu:mailman:2.0.5:*:*:*:*:*:*:*2.0.5VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.6:*:*:*:*:*:*:*2.0.6VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.7:*:*:*:*:*:*:*2.0.7VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.8:*:*:*:*:*:*:*2.0.8VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.9:*:*:*:*:*:*:*2.0.9VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.10:*:*:*:*:*:*:*2.0.10VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.11:*:*:*:*:*:*:*2.0.11VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.12:*:*:*:*:*:*:*2.0.12VulnerableGNU
cpe:2.3:a:gnu:mailman:2.0.13:*:*:*:*:*:*:*2.0.13VulnerableGNU
cpe:2.3:a:gnu:mailman:2.1:*:*:*:*:*:*:*2.1VulnerableGNU
cpe:2.3:a:gnu:mailman:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableGNU
cpe:2.3:a:gnu:mailman:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableGNU
cpe:2.3:a:gnu:mailman:2.1.3:*:*:*:*:*:*:*2.1.3VulnerableGNU
cpe:2.3:a:gnu:mailman:2.1.4:*:*:*:*:*:*:*2.1.4VulnerableGNU
cpe:2.3:a:gnu:mailman:2.1b1:*:*:*:*:*:*:*2.1b1VulnerableGNU
  • cpe:2.3:a:gnu:mailman:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.7:*:*:*:*:*:*:* Versions 2.0.7 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.8:*:*:*:*:*:*:* Versions 2.0.8 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.9:*:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.10:*:*:*:*:*:*:* Versions 2.0.10 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.11:*:*:*:*:*:*:* Versions 2.0.11 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.12:*:*:*:*:*:*:* Versions 2.0.12 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.0.13:*:*:*:*:*:*:* Versions 2.0.13 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·GNU
  • cpe:2.3:a:gnu:mailman:2.1b1:*:*:*:*:*:*:* Versions 2.1b1 Vulnerable ·GNU

Remediation

  • Fix · GHSA-rh6c-jh4c-9fg3 mailman (PyPI) Fixed in 2.1.5 Advisory →

Red Hat 1 advisory

  • RHSA-2005:235 Released 2005-03-21 · Red Hat rating Important
    mailman security update
    • Red Hat Desktop version 3 mailman-3:2.1.5-25.rhel3, mailman-3:2.1.5-25.rhel3.i386
    • Red Hat Enterprise Linux AS version 3 mailman-3:2.1.5-25.rhel3, mailman-3:2.1.5-25.rhel3.i386, mailman-3:2.1.5-25.rhel3.ia64 +1
    • Red Hat Enterprise Linux AS version 4 mailman-3:2.1.5-33.rhel4, mailman-3:2.1.5-33.rhel4.i386, mailman-3:2.1.5-33.rhel4.ia64 +1
    • Red Hat Enterprise Linux Desktop version 4 mailman-3:2.1.5-33.rhel4, mailman-3:2.1.5-33.rhel4.i386
    • Red Hat Enterprise Linux ES version 3 mailman-3:2.1.5-25.rhel3, mailman-3:2.1.5-25.rhel3.i386, mailman-3:2.1.5-25.rhel3.ia64
    • Red Hat Enterprise Linux ES version 4 mailman-3:2.1.5-33.rhel4, mailman-3:2.1.5-33.rhel4.i386, mailman-3:2.1.5-33.rhel4.ia64
    • Red Hat Enterprise Linux WS version 3 mailman-3:2.1.5-25.rhel3, mailman-3:2.1.5-25.rhel3.i386, mailman-3:2.1.5-25.rhel3.ia64
    • Red Hat Enterprise Linux WS version 4 mailman-3:2.1.5-33.rhel4, mailman-3:2.1.5-33.rhel4.i386, mailman-3:2.1.5-33.rhel4.ia64

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Desktop version 3Fixed RHSA-2005:235
Red Hat Enterprise Linux AS version 3Fixed RHSA-2005:235
Red Hat Enterprise Linux AS version 4Fixed RHSA-2005:235
Red Hat Enterprise Linux Desktop version 4Fixed RHSA-2005:235
Red Hat Enterprise Linux ES version 3Fixed RHSA-2005:235
Red Hat Enterprise Linux ES version 4Fixed RHSA-2005:235
Red Hat Enterprise Linux WS version 3Fixed RHSA-2005:235
Red Hat Enterprise Linux WS version 4Fixed RHSA-2005:235

Timeline

  1. 2026-10-02 Threatist record created from CVE-2004-1177
  2. 2026-10-03 Alias added: GHSA-rh6c-jh4c-9fg3

References

  • TI-2025-28486 Path traversal in GNU Mailman CVSS 3.1HIGH 7.5
  • TI-2025-28487 OS command injection in GNU Mailman CVSS 3.1HIGH 8.1
  • TI-2025-28488 Incorrect authorization in GNU Mailman CVSS 3.1MEDIUM 5.3
  • TI-2015-02450 Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static… CVSS 2.0HIGH 7.6
  • TI-2002-00830 Cross-site scripting vulnerability in Mailman before 2.0.12 allows remote attackers to… CVSS 2.0HIGH 7.5
  • TI-2002-00374 Cross-site scripting vulnerabilities in Mailman before 2.0.11 allow remote attackers to… CVSS 2.0HIGH 7.5
See all 46 →

Sources